All may External USB hard drive doesn't mount

Discussion in 'Mac Accessories' started by djorge, Apr 24, 2009.

  1. djorge macrumors newbie

    Joined:
    Aug 31, 2008
    #1
    Hi,

    Something weird is happening with my mac.
    My mac is a MacBook Pro 2.6 early 2008.

    Last night i was using my mac in battery mode and my macbook pro just turned off wihout warning me that the battery is almost empty. i was trying to deplete the battery to get a better performance with the batt.

    What is happening is that i have an external usb drives with NTFS and it doesn't get mount. The console error is:

    The drive appears in Disk Utility but whenever i try to mount it via DiskUtility it says that the drive can't be mounted.

    I also have VMWare fusion and the drive is mounted in windows (via VMWare), and everything is fine with its contents and filesystem. This is weird!!

    I really need your help guys. Anyone, please?

    I also tried with my other external usb drive and the same behavior is happening.

    Thanks in advance,
    djorge
     
  2. TXBDan macrumors regular

    Joined:
    Oct 19, 2008
    Location:
    Boston, MA
    #2
    Same situation here. bump for help.


    This all worked fine and dandy for ages. Then i was just running Win7 in VMware fusion and plugged in my external NTFS drive. it didn't show up in either OS.

    Closes VMware, shows up in disk util, but won't mount. rebooted into windows, the drive seems to be fine. back to mac, shows up in DU,but won't mount.

    I have Paragon NTFS for Mac on the system. With it enabled or disabled, the drive still won't mount.
     
  3. djorge thread starter macrumors newbie

    Joined:
    Aug 31, 2008
    #3
    Hi TXBDan,

    i end up reinstalling Leopard due to lack of help.

    But in my case i was able to see the usb disk in VMWare fusion with windows xp. But on Leopard only DU seems to know it and i couldn't mount it.

    I have a TimeCapsule and now i can say from experiente that TimeCapsule sucks for full restore. I had to wait 300 hours (with ethernet cable).

    what happened in your case? Right after installing Windows 7 RC1? My problem started right after the hard shutdown.
     
  4. djorge thread starter macrumors newbie

    Joined:
    Aug 31, 2008
    #4

Share This Page