All my app icons are mixed up

Discussion in 'iPhone Tips, Help and Troubleshooting' started by nojokews6, Jun 29, 2009.

  1. nojokews6 macrumors regular

    Joined:
    Jun 24, 2008
    #1
    For example the shazam app has the eBay icon.. 50% of my apps are this way. Is this a 3.0 bug or is there a way to fix it?
     
  2. TheNewsPaperBoy macrumors regular

    TheNewsPaperBoy

    Joined:
    May 10, 2009
    Location:
    Florida
    #2
    Do you have a 3G or 3GS? My 3GS are that way, but mine also has some other mechanical issues...
     
  3. conshok26 macrumors 6502

    conshok26

    Joined:
    Apr 10, 2006
    Location:
    North Tonawanda, NY
    #3
    I believe this is a known bug with the 3.0 software. Should be addressed when 3.0.1 comes out hopefully soon.
     
  4. tivoboy macrumors 68030

    Joined:
    May 15, 2005
    #4
    correct?

    is there a way to correct this? This happened to mine today, after the phone just literally DIED last night. Not battery, but something else, had to do a hard reset on it.
     
  5. conshok26 macrumors 6502

    conshok26

    Joined:
    Apr 10, 2006
    Location:
    North Tonawanda, NY
    #5
    the only way i know as of right now is to un sync your apps then re sync.
     
  6. WilliamG macrumors 604

    Joined:
    Mar 29, 2008
    Location:
    Seattle
    #6
    Yep had this happen to me yesterday on my 3GS. A definite 3.0 bug. Had to un-sync and re-sync.
     
  7. That70sGAdawg macrumors 6502

    That70sGAdawg

    Joined:
    May 23, 2008
    Location:
    N.Georgia, USA (on the Lake, near the Mountains)
    #7
    A complete restore 3 days ago only lasted until today. Now they're all mixed up again on my 10 day old 3GS.
    We need a software fix NOW!!!
     
  8. PhxBlue macrumors regular

    PhxBlue

    Joined:
    May 24, 2008
    Location:
    The Valley, AZ
    #8
    I have this problem too. I uninstall and reinstall the affected apps. It's only a temporary fix though.
     
  9. coolbreeze macrumors 65816

    Joined:
    Jan 20, 2003
    Location:
    UT
    #9
    Day two of my 3GS life. Got it yesterday.

    My apps are all mixed up as well. Frustrating.

    Doing a remove/re-install now.
     
  10. Ronnoco macrumors 68030

    Ronnoco

    Joined:
    Oct 16, 2007
    Location:
    United States of America
    #10
    This fix has worked for many of us...it seems a bit strange, but it really does work (I used facebook as the app I deleted)...

    There is a way to fix this. You have to delete one of the apps that is messing up from your iPhone (preferably a free one that doesn't have any information stored that you don't want to lose). Then go back to the App Store on your iPhone, and redownload the application you just deleted. Once is starts downloading click on the app icon to pause the download process, then turn off your phone only using the slider (not a hard reset). Turn your iPhone back on and finish the download. This should fix the icons for all of the apps. At least it has been working for me

    Props to codeunrwolfpack for figuring out this rather strange fix! :D
     
  11. mackmgg macrumors 65816

    mackmgg

    Joined:
    Nov 2, 2007
    #11
    Another way to do this is to just respring. If you're jailbroken, you can enable a winterboard theme with at least one icon to prevent this.
     
  12. lavinci macrumors 6502

    Joined:
    Jun 19, 2009
    #12
    Resync the apps by deleting them off your phone and syncing them again in iTunes.
     
  13. santybm macrumors newbie

    Joined:
    Apr 10, 2009
    #13
    icon bug

    I put the applications with the wrong icon with the ones that have the correct icon.
     

    Attached Files:

  14. Ronnoco macrumors 68030

    Ronnoco

    Joined:
    Oct 16, 2007
    Location:
    United States of America
    #14
    I never had the problem again following this fix
     
  15. sparkles61785 macrumors regular

    Joined:
    Jun 13, 2009
    Location:
    New York
    #15
    This worked for me. Thank you so much. :D
     
  16. hexonxonx macrumors 601

    Joined:
    Jul 4, 2007
    Location:
    Denver Colorado
    #16
    I never had this problem until I downloaded Yelp. I noticed on Sunday that Yelp had the Facebook icon and so did Facebook. I tried deleting Yelp and then reinstalling and it still had the Facebook icon. Finally I just deleted Yelp since I really have no use for it.

    I also noticed on Sunday for the first time that on another iPhone, two of it's icons were the same on two differant apps. I deleted one and reinstalled it and the icons were ok.
     

Share This Page