all my apps are crashing!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Soundhound, Aug 16, 2008.

  1. Soundhound macrumors 6502a

    Joined:
    Mar 29, 2006
    #1
    All the ones I've gotten from the iTunes store thatis. The ones that came with my iphone (3g) seem fine. I tried restarting , hasnt helped. anybody experienced this? Help!!!
     
  2. TheBearman macrumors 6502

    Joined:
    May 23, 2008
    Location:
    Cary, NC
    #2

    Welcome to the club... Read this....

    http://forums.macrumors.com/showthread.php?t=537779
     
  3. d_saum macrumors 6502

    d_saum

    Joined:
    Jun 14, 2005
    Location:
    NC
    #3
    I just posted a thread about this too. Try updating from the app store. I had 6 updates, but surprisingly, it fixed ALL my apps.

    On a side note.... do you look at other threads before you post? I did a search and read through 3 pages before I posted mine. If you had read even the first page of threads you should've seen mine.
     
  4. Soundhound thread starter macrumors 6502a

    Joined:
    Mar 29, 2006
    #4
    I did a restore, we'll see how that goes. I forgot to back up my apps though, so I probably lost those :(


    To your side note. No I didn't look at other threads on this issue. I do always try to do that before posting on any forum of course. But this was alarming and I was out and about and hopped on Safari to see if I could get some quick help. If this thread inconvenienced you in some way, maybe you should just not read it.


     
  5. Soundhound thread starter macrumors 6502a

    Joined:
    Mar 29, 2006
    #5
    I did a full restore. It did hold onto the third party apps however.

    And all third party apps still crash immediately. this sucks.
     
  6. SDAVE macrumors 68040

    SDAVE

    Joined:
    Jun 16, 2007
    Location:
    Nowhere
    #6
    I was just about to post this...

    Ok what happens is I disabled all the syncing via iTunes (I like it manual) and whenever I plug the phone to the computer and drop in music directly into the iPhone (instead of getting it from my iTunes library, I don't buy stuff from iTunes, I rip my original CD's into MP3) and when I disconnect, all the apps I've had on the iPhone are gone. I hope Apple fixes this.
     
  7. darkfiber macrumors 6502a

    darkfiber

    Joined:
    Jul 13, 2008
    Location:
    Columbus, OH USA
    #7
  8. Italchef macrumors 6502

    Joined:
    Nov 3, 2003
    Location:
    Maple, Ontario
    #8
    The fix for this seems to be the purchase and installation of the third party apps through iTunes and not to use the phone itself. Sort of defeats the purpose of having the App store on the iPhone but until its fixed, this is the way around it.
     
  9. meagain macrumors 68030

    Joined:
    Nov 18, 2006
    #9
    Not true.

    Soundhound - can you pinpoint exactly when this started? And when you updated iTunes 7.7.1 and 2.0.1?
     
  10. Italchef macrumors 6502

    Joined:
    Nov 3, 2003
    Location:
    Maple, Ontario
    #10
    I'm sorry, but what about this is not true? The solution outlined here is taken directly from the link in the post above, and I also heard it offered on Macbreak Weekly. If this is not the way to solve this issue, please let us know and substantiate your reply.

    Mick
     
  11. meagain macrumors 68030

    Joined:
    Nov 18, 2006
    #11
    Because I have 4 iPhones in the house (two 2g & two 3g) and not one has downloaded or updated an app via the phone directly. Nor was ANYthing purchased over the phone. All done over the computer and all are having problems. You'll find many fixes/fix attempts for this that are all over the place from blaming a certain app to plague of locusts. That doesn't mean they are right.

    I'm reverting my iTunes to 7.7.0 as a test.
     
  12. Italchef macrumors 6502

    Joined:
    Nov 3, 2003
    Location:
    Maple, Ontario
    #12
    I'm sorry to hear that. The fix worked for me thankfully. The only suggestion that I can make is: Leo Laporte had said that he had to do a full restore on his phone and not to use the backup. He said that he had to do this 3 times before all was in order. From what I understand, and trust me I'm no expert just an average user, the problem is with the 2.0 upgrade. I sure hope that they fix this one in the next revision.
    Good luck
    Mick
     
  13. meagain macrumors 68030

    Joined:
    Nov 18, 2006
    #13
    IDK - I'm about to give up. I just totally deleted iTunes and installed the old 7.7 version. Nothing. I admit I didn't restore then though but I have restored many times. I think my library is messed up or something.
    I'm loading ALL my apps through this computer despite knowing they won't open on the phone and transferring them to my laptop on a 7.7 iTunes to see if some magic happens.

    Everything was fine for me on both 2g & 3g phones after 2.0 till I upgraded both iTunes to 7.7.1 and phone to 2.0.1 on Aug. 9. Seems even then it worked for a few days. But I'm about ready to give up and be patient and wait for Apple.

    IF things work on my other computer by transferring the bad-acting apps on my phone - then it'll be interesting. Maybe LOL
     
  14. Soundhound thread starter macrumors 6502a

    Joined:
    Mar 29, 2006
    #14
    I have soiftware update set to once a month, so I think I've probably had iTunes 7.7.1 for a while.

    For the record, I did a full reset of the iPhone last night. I forgot to save the apps, I thought, but they somehow were still on there after the full reset.
    I still had the same problem with app store apps quittting.

    This morning I tied deleting a few, and redownloading them (which as someone here nicely explained the vendors seem to let you do as part of the normal process) everything seems to be fine.

    Some very nasty rev.1 bugs must be going on here. Need to tread lightly with this till they get it more stable... thanks everyone.!!

     
  15. meagain macrumors 68030

    Joined:
    Nov 18, 2006
    #15
    I'm having success. I'm using another computer with 7.7 on it. I don't 'think' the version is what's helping but just a clean, uncorrupted iTunes? I'm populating that computer's iTunes with the apps. So far all the apps are working. Pages of them. Course this might change in the next few minutes. :)

    Anyone know how to 'completely' blow out iTunes including ALL traces and past libraries, etc? Most instructs are geared towards saving that. I feel that's where the problem is.
     

Share This Page