All my video playback is choppy and the remote is sluggish

Discussion in 'Apple TV and Home Theater' started by hualon, Mar 27, 2009.

  1. hualon macrumors 6502

    Joined:
    Feb 5, 2008
    #1
    I've just about had it.

    Problem: All videos are choppy and lose audio sync as the file progresses. The remote control responsiveness is also very... sluggish.

    Symptoms / Relevant Data:
    1. No synchronizing, streaming only
    2. WIRED network connection
    3. ATV hard drive seems to be chugging away non-stop
    4. ATV is very hot (although I think this is typical)
    5. ATV is connected directly to Linksys WRT54G2 V1
    6. Mac Pro 2.8 8-core is host with FW-800 Drobo as data storage unit
    7. Test file play perfectly through iTunes
    MPEG-4 video file, 1.53GB, 125kbps bit rate, Low Complexity, Stereo, 3566kbps total bit rate, 960x540 video dimensions, H.264 codec.
    8. :confused:
    9. :mad:

    Can you help me out?
     
  2. Rich1963 macrumors 6502

    Joined:
    Jul 18, 2008
    #2
    Couple of baseline questions-

    -Have you done the complimentary restart?
    -When you restart the AppleTV, does it play the opening video smoothly?
    -Not that it's ever said anything but 'normal', what do the diagnostics say?
    -If your hard drive is churning non-stop, it almost sounds like it's a constant page in/page out problem (bad drive).
    -Is the Drobo running the latest firmware?
    -I assume by you mentioning FW800 Drobo, it's tied directly to the Mac?
    -Do you have an alternative drive you could hook-up and play a video off of to exclude the Drobo as the culprit?
    -How full is the Drobo?
    -Do you have an alternative router you could try, or hook the Cat 5 cable directly to the Mac to exclude router issues?
    -How old is the AppleTV?
    -What hard drives are in the drobo (manufacturer and size)? Hopefully it's not the Seagate 1.5 TBs.
    -Is it hacked with anything?
    -Do you have a normal res DVD source you could play (i.e. not a 540p res movie)?

    Just a few things to try before putting a bullet into the AppleTV? Like Tom Arnold said in "Austin Powers", "Hold my hand. We'll get through this".
     
  3. hualon thread starter macrumors 6502

    Joined:
    Feb 5, 2008
    #3
    Followup. I was mistaken and I DID have "Sync TV Shows" checked and the hard drive was completely filled with shows. I unchecked that box and now the same video files that were choppy yesterday are smooth sailing today.

    Weird.
     
  4. Rich1963 macrumors 6502

    Joined:
    Jul 18, 2008
    #4
    That's great, though. Now you'll be cracking a beer tonight out for relaxation and not frustration. Have a good weekend.:D
     
  5. hualon thread starter macrumors 6502

    Joined:
    Feb 5, 2008
    #5
    Well I spoke too soon. The problem persists.

    I've done some more testing and found that all videos exhibit this symptom. This includes videos I've ripped from DVD using Handbrake (AppleTV Preset) and TV shows converted via Elgato's EyeTV AppleTV export preset.

    It looks like this: you start a movie or show and every couple of minutes the blue bar pops up on the bottom and the octopus spins around for a second or two, and then the video resumes for another minute or two.

    It feels like the buffer is just not filling fast enough but I'm on wired Ethernet and there isn't even any other activity on the network.

    Hurumph. Ideas?
     
  6. Rich1963 macrumors 6502

    Joined:
    Jul 18, 2008
    #6
    Well, then we're back to the Drobo or the network question. When EXACTLY did this problem start? I think what you should do is stream a movie to the AppleTV off of your desk top. And if possible, directly over cat5 from the mac to the appleTV. This will eliminate routers and the Drobo. Then, troubleshooting 101, i.e. start introducing variables back into the equation.
     
  7. hualon thread starter macrumors 6502

    Joined:
    Feb 5, 2008
    #7
    OK I restored the ATV to factory settings and reinstalled the latest software. I established a link to my library and synchronized one TV series and one movie. The movie was encoded with Handbrake ATV preset and the TV show was encoded using EyeTV ATV preset.

    I copied those videos over to the ATV and started playing them back with the same buffering result.

    This rules out the Drobo and my network, right?
     
  8. Rich1963 macrumors 6502

    Joined:
    Jul 18, 2008
    #8
    The only thing at this point I can guess at is it's either the hard drive or something olse internal. If the warranty is up, you might want to look up either Nightstorm, Dynaflash, or Caveman, either here or on the Handbrake forum with regards to a hard disk replacement. Don't know where else to go at this point.

    One last question, though. Is this connected via HDMI or composite? There's a slim (read: really slim) outside chance it's a bad HDMI cable. How old was this AppleTV again?
     
  9. hualon thread starter macrumors 6502

    Joined:
    Feb 5, 2008
    #9
    The ATV is around 1.5 years old, maybe 2. I'm using HDMI but I haven't tried another cable yet. I suppose that's next...

    J
     
  10. Rich1963 macrumors 6502

    Joined:
    Jul 18, 2008
    #10
    Unfortunately this is probably also the last thing I can think of. If anyone else is paying attention to this thread, what's the failure rate like with these things after two years? It's seems like an inordinate amount of them are going belly up in this time frame? Any ideas on prolonging life? Heat removal? Anyone?
     
  11. hualon thread starter macrumors 6502

    Joined:
    Feb 5, 2008
    #11
    Well I reverted to 1.1 firmware and I'm going to try it out tonight. I remember when I "upgraded" to Take 2 that the ATV stopped streaming altogether. I bought a new network switch, changed nothing else, and it worked perfectly again. What's THAT all about?

    Nothing from the Apple corporation has caused me as much ire as the Apple TV.

    edit: I forgot to mention that I switched to a new HDMI cable and the problem persisted. I also took the box into the A store today but they ran the diagnostic tool and declared that the box was fine. Great. Big help, Fruit.
     
  12. hualon thread starter macrumors 6502

    Joined:
    Feb 5, 2008
    #12
    I have been using 1.1 firmware all night and everything I've tried to play has played without any problem. Sync, stream, iTunes content, ripped DVDs (Handbrake), transcoded video downloads (VisualHub), EyeTV Recordings, etc. No problems.

    So now why does the 2.3 firmware screw up my universe so much?
     
  13. cawesjmu macrumors 6502

    Joined:
    Apr 4, 2004
    Location:
    Richmond, VA
    #13
    Did you try switching back to the old network router/switch while on Apple TV 1.1? I'm just curious if it's really the software, or if the new switch fixed the problem. I'm curious because I'm thinking of getting an ATV, which could be wired, but I'm afraid of video stutter.
     
  14. NightStorm macrumors 68000

    Joined:
    Jan 26, 2006
    Location:
    Whitehouse, OH
    #14
    Upgrade to 2.3 with the new switch. The replacement of the switch is a huge change to the network.
     
  15. hualon thread starter macrumors 6502

    Joined:
    Feb 5, 2008
    #15
    I did this about a year ago or something. I've been running 2.3 with the new switch without error for a few months.

    J
     

Share This Page