All of the sudden, XCode wont deploy to my iPhone

Discussion in 'iOS Programming' started by SqueegyX, Oct 23, 2008.

  1. SqueegyX macrumors regular

    Joined:
    Mar 24, 2008
    #1
    I had this working great for a while. Until today when I bought a few apps on the app store and sync'd. Now XCode won't run my app on my device at all. It gives me the 0x8E0000... error. I've rebooted my computer and my phone multiple times, and double checked my certificate and compilign settings and all looks right.

    2 things that make this bizarre:

    * I have another app that I can run on the phone fine right from XCode, using the same settings and certificates.
    * I can build the app, and install it in iTunes via an adhoc provision, and sync and the app shows up just fine.

    What the hell?
     
  2. abyram macrumors newbie

    Joined:
    Oct 23, 2008
    #2
    Remove iTunesArtwork

    I had this issue recently - in my case, it was the fact that I had the iTunesArtwork file in my project's bundle (from the last ad hoc compile). Apparently, if that file is present, you can't deploy the app in regular device debug mode. If you don't have an iTunesArtwork file in your project, then of course this won't be of use, but if you do happen to have that file in your project, just remove the reference to it from the project, do a build->clean, and then you should be good to go.

    - Adam
     
  3. SqueegyX thread starter macrumors regular

    Joined:
    Mar 24, 2008
    #3
    Sadly, I have no such file :(

    XCode's error reporting about these issues leave a lot to be desired.

    I do get this in the console though:

    Code:
    Thu Oct 23 18:37:43 unknown afcd[214] <Error>: user mobile has uid 501
    Thu Oct 23 18:37:43 unknown afcd[214] <Error>: mode is 0x41e8
    
    Which is completely unhelpful.
     
  4. SqueegyX thread starter macrumors regular

    Joined:
    Mar 24, 2008
    #4
    Ok, now this is really wierd.

    I start a brand new project with the same name as the one that wont install. This app refuses to install.

    Now, I start another new project with a different name, and I get that to install just fine. Somehow XCode or my iPhone is now choking on the app name.

    Maybe my app never got uninstalled properly and now its stuck in limbo where I cannot delete it because it has no icon on my phone, nor can I install.

    I already tried a restore to my last backup, and that didnt fix it. Is my dev phone hosed? Do I have to reset it completely and lose all my prefs and data in order to get this working again?
     
  5. SqueegyX thread starter macrumors regular

    Joined:
    Mar 24, 2008
    #5
    I solved this, but only indirectly.

    I had to restore my iPhone, then load the backup. All my settings came back over, and the worst that happened was that my icons lost their arrangement.

    But whatever was broken got cleared out.
     

Share This Page