All USB external hard drives no longer mounting

Discussion in 'Mac Basics and Help' started by iamalexc, Apr 23, 2016.

  1. iamalexc macrumors newbie

    Joined:
    Apr 23, 2016
    #1
    Hi guys,

    While fixing my 13” (2013) Macbook Air’s wifi problems (which had been going on for 2 years), I ended up creating a new problem for myself.

    I was getting constant connection dropouts at home and speeds that make 56K dial up look like ADSL so I tried solutions that I found from a couple forums that appeared to fix their issues:
    - I downloaded Kext Wizard and installed the Kext and went to maintenance and ran the permissions repair (yes I made a backup of the original)
    - I downloaded Kext Utility and ran it and installed the Kext named ‘IO80211Family.kext’

    I know, I probably shouldn’t have ran both apps but the first one didn’t appear to work so I tried the other.

    Eventually my wifi issues actually did get resolved but I’m not even sure if it was from these Kext apps as I also changed some router settings. Anyway I was happy as heck when my wifi was seeing normal speeds for the first time in 2 years, however, when I went to plug in my 1TB Toshiba Canvio portable hard drive I found it did not show up anymore.

    I then tried just a regular USB stick and that didn’t show up anymore either!

    I found that they do show up in Disk Utility but the drive’s name is grayed out and when I attempt to mount it, I get an error message (“Mount failed - The disk “EXTHARDDRIVE” could not be mounted. Try running First Aid and then retry mounting.”)

    So then I do a ‘Verify Disk’ on the external hard drive and there are no errors. I do a ‘Repair Disk’ on the external hard drive and there are no errors either.

    But when I go to mount the drive it again comes up with the same error…

    Solutions I’ve tried that didn’t work:
    - Disk Utility verify and repair on both my own hard drive and the external drive
    (When I click on Macintosh HD and click ‘Verify Disk’ it comes up with an error message “Alert - Couldn’t mount disk.” and the same thing happens when I try to repair)
    - Resetting the PRAM
    - Resetting the SMC
    - Unplugging everything and restarting the computer
    - My preferences in Finder are set to show external hard drives on desktop and in Finder
    - Attempting to mount via Terminal

    Things to note:
    - I am able to get the external hard drive to mount only when I boot up in Recovery Mode
    - The drive is formatted as a FAT

    My guess is it’s not the external drives because they both work on my brother’s Macbook and none of them work on mine.
    It must have something to do with the Kext installation that I was messing around with.

    So after spending 12 hours of the last 3 days trying to fix this issue I am tapped out and I think I need some assistance :( Anyone got any ideas?
     
  2. richard2, Apr 23, 2016
    Last edited: Apr 23, 2016

    richard2 macrumors regular

    richard2

    Joined:
    Oct 21, 2010
    Location:
    England, United Kingdom
    #2
    I'm afraid you've almost certainly damaged your OS X installation; therefore, I'd recommend that you reinstall OS X.

    Regarding the Wi-Fi issue: does it occur while using other Wi-Fi networks?
     
  3. iamalexc thread starter macrumors newbie

    Joined:
    Apr 23, 2016
    #3
    Thanks for taking the time to reply

    I'm cool with having to reinstall OS X, as long as I know that it'll actually fix the problem

    The Wi-Fi issue was only happening at home, but whenever I was anywhere else it was working fine
     
  4. richard2 macrumors regular

    richard2

    Joined:
    Oct 21, 2010
    Location:
    England, United Kingdom
    #4
    I only suggest solutions that I believe have a high chance of success. ;)

    In that case, the cause of the issue is wireless interference or a faulty router.
     
  5. boast macrumors 65816

    boast

    Joined:
    Nov 12, 2007
    Location:
    Phoenix

Share This Page