All Videos on iTunes Choppy

Discussion in 'Mac Apps and Mac App Store' started by gretschdrummer, Mar 11, 2012.

  1. gretschdrummer macrumors member

    Joined:
    Sep 1, 2011
    #1
    Hi. I am running iTunes 10 on a Macbook 1,1. Whenever I play any video, doesn't matter if it's HD or not, the video is skipping frames and sometimes freezes. Then after about five seconds or so, video playback is normal. I know this is an iTunes issue since I can play the same videos on Quicktime just fine. I don't know if this was a problem before I updated iTunes, since I just received this laptop. Anybody know what the problem is? Thanks.
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    What Mac OS X version and iTunes version do you run?
     
  3. gretschdrummer thread starter macrumors member

    Joined:
    Sep 1, 2011
    #3
    10.6.8 for the Mac and iTunes 10.1 (the latest version)
     
  4. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #4
    10.6 is the latest iTunes version.
    Are the videos SD or HD and in what QT Player version do they play fine?
     
  5. gretschdrummer thread starter macrumors member

    Joined:
    Sep 1, 2011
    #5
    The videos in particular I'm talking about are in SD, but it happens on every video in iTunes, iTunes Store downloaded or not. The videos work fine on Quicktime 10.0 and VLC 1.0.5. It seems like iTunes has trouble when I select a certain part of the video as the choppiness usually occurs there for a few seconds then freezes. Same happens when I start the video.
     
  6. bjeong1381 macrumors newbie

    Joined:
    Aug 2, 2011
    #6
    I am having the same issue. Seems to have started happening after this last update. I cannot recall if it was like this before the update.
     
  7. ohsoez macrumors newbie

    Joined:
    Jul 3, 2012
    #7
    Choppy Video

    I'm adding this because I keep forgetting. The basic problem is your wireless router. I had a linksys router (black with the blue bar) and there is some issue with the apple computers and the newness of new routers. Once I bought a new wireless router everything is just fine. (This is thanks to the Apple guy at Best Buy). It has something to do with the speed or compression or mhz or something and it's the router's fault not the computer. If your router is more than a year old, get a new one. Don't download anything and dont sign up for any of the apple cleaning things.
     

Share This Page