Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

Kallen

macrumors member
Original poster
Jan 17, 2013
35
2
Hey all. So, I recently upgraded from a 7+ to an 11. On my 7+ I had trouble with WiFi with webpages loading. I didn’t notice an issue with streaming/media apps but Safari take forever to load pages - sometimes over 30 seconds to load google results or open pages. Turn off WiFi and pages load immediately. Thought it was the phone because it was having other issues. Few days ago got a shiny new iPhone 11. Restored from backup and guess what? New phone does the same thing! Exact same behavior when loading pages. So I did a “reset all settings” thinking I must have brought over something from the old phone. No change. The only fix I really found online was changing the DNS to manual and set to 8.8.8.8. That didn’t fix this issue either. It is definitely NOT my router as this behavior happens on any WiFi connection and this issue does not affect my iPad or any other device. Any thoughts?

EDIT: I noticed that search results within the Amazon app is slow as well but it seems more random and inconsistent whereaswhen browsing through Safari is consistent
 
Last edited:

tomowl

macrumors member
Jun 15, 2015
84
86
It happens to me too. I have to turn WiFi off for something to load. iPhone 11 Pro Max.
 

bunnyechoes

macrumors member
Nov 25, 2017
52
43
Slovenia
Do you have a smart watch/tracker such as Fitbit? I have noticed my phone works a lot slower on wifi if it's connected to my Charge 3. Try turning bluetooth off and see what happens.
 

Kallen

macrumors member
Original poster
Jan 17, 2013
35
2
Do you have a smart watch/tracker such as Fitbit? I have noticed my phone works a lot slower on wifi if it's connected to my Charge 3. Try turning bluetooth off and see what happens.

As a matter of fact yes, I do have a Fitbit Versa. And I believe the timing would have been right with my 7+ when this started. I will disable it for a few days and see what happens. Thanks for that suggestion.
 

Kallen

macrumors member
Original poster
Jan 17, 2013
35
2
Update: I disabled the Bluetooth and immediately noticed the browser is a lot faster and no longer hangs. After 2 days I re-enabled the BT and so far it’s still working normally. I’m not sure I fully understand why disabling for a certain period would correct the issue, not why it’s not working correctly. I don’t want to mark as solved just yet but this is definitely a step in the right direction. Thanks for the suggestion!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.