Allow non-digitally app to run hides

thealiendad

macrumors member
Original poster
Jun 27, 2015
61
18
UK
This is not a typo, when i try and start Parallels desktop on High Sierra i get a message saying go to security etc if you want to allow Parallels to run.
When the screen opens, for a fraction of a second i can see the allow box, but before i have chance to click on 'allow' the menu has changed to show only 'allow apps from apple only or apple & others.

Anyone else seen this issue, or better still, knows how to resolve it? ;-)
 

mikecwest

macrumors 6502a
Jul 7, 2013
980
344
You need to go to setting and allow parallels to control your Mac. It seems English is not your primary language, so you question is not really clear .


Are you running the newest version of parallels?
 

thealiendad

macrumors member
Original poster
Jun 27, 2015
61
18
UK
You need to go to setting and allow parallels to control your Mac. It seems English is not your primary language, so you question is not really clear .


Are you running the newest version of parallels?
Yes i am, but i am more wondering why the function to allow non-digitally signed apps disappears. :)
 

Attachments

ryxn

macrumors regular
Jun 5, 2017
116
27
They are trying to protect you from harm.
Correct. I believe with Parallels, you may also need to go to Settings > Security & Privacy > Privacy > Accessibility and give Parallels permissions to control your computer.
 

thealiendad

macrumors member
Original poster
Jun 27, 2015
61
18
UK
Correct. I believe with Parallels, you may also need to go to Settings > Security & Privacy > Privacy > Accessibility and give Parallels permissions to control your computer.
Thanks for the suggestion but Parallels is already enabled on Accessibility menu.

by doing a video screen grab and scanning one frame at a time i was able to view the 'allow' function before it disappears.
 

Attachments

mikecwest

macrumors 6502a
Jul 7, 2013
980
344
this is snagged from a google search:

How to reinstate the Anywhere setting in Gatekeeper
  1. Close System Preferences on your Mac.
  2. Open Terminal.
  3. Type the following command: sudo spctl --master-disable.
  4. Hit enter on your keyboard.
  5. Enter your administrator password.
  6. Hit enter on your keyboard.
stolen from : https://www.imore.com/how-open-apps-unidentified-developers-mac
[doublepost=1501528745][/doublepost]
Thanks for the suggestion but Parallels is already enabled on Accessibility menu.

by doing a video screen grab and scanning one frame at a time i was able to view the 'allow' function before it disappears.
this will do it.
 

thealiendad

macrumors member
Original poster
Jun 27, 2015
61
18
UK
this is snagged from a google search:

How to reinstate the Anywhere setting in Gatekeeper
  1. Close System Preferences on your Mac.
  2. Open Terminal.
  3. Type the following command: sudo spctl --master-disable.
  4. Hit enter on your keyboard.
  5. Enter your administrator password.
  6. Hit enter on your keyboard.
stolen from : https://www.imore.com/how-open-apps-unidentified-developers-mac
[doublepost=1501528745][/doublepost]
this will do it.
Thanks, but that only enables the 'download' from anywhere, not run.
 

mikecwest

macrumors 6502a
Jul 7, 2013
980
344
Thanks, but that only enables the 'download' from anywhere, not run.
It should make it stay like the first picture and not change to the second one.

I would think that if you had the newest release of parallels 12, it would not be an issue anyway. I know there are some cracked apps, that will give you further trouble, and have been compromised in some way....(At the very minimum to put a "hack credit" such as a little shark on the icon and about dialogs.) I am assuming though, that your copy is legit, however if it is not, a legal copy will rectify that right away.

You can also try right clicking and selection OPEN from the drop down...Some times, it takes a second try for some reason.....and in case you have a track pad, and don't know you can "two finger press and hold" to perform a "right click."
 

thealiendad

macrumors member
Original poster
Jun 27, 2015
61
18
UK
It should make it stay like the first picture and not change to the second one.

I would think that if you had the newest release of parallels 12, it would not be an issue anyway. I know there are some cracked apps, that will give you further trouble, and have been compromised in some way....(At the very minimum to put a "hack credit" such as a little shark on the icon and about dialogs.) I am assuming though, that your copy is legit, however if it is not, a legal copy will rectify that right away.

You can also try right clicking and selection OPEN from the drop down...Some times, it takes a second try for some reason.....and in case you have a track pad, and don't know you can "two finger press and hold" to perform a "right click."
I have the newest and it is a legit version of Parallels and the issue still occurs. My mouse is setup with right click functionality but clicking on open still has the same result.

Does anyone know of another app that should make High Sierra react in the same way?
 

thealiendad

macrumors member
Original poster
Jun 27, 2015
61
18
UK
I have the newest and it is a legit version of Parallels and the issue still occurs. My mouse is setup with right click functionality but clicking on open still has the same result.

Does anyone know of another app that should make High Sierra react in the same way?
so can anyone suggest a non-digitally signed app so i can see if the issue occurs with others? :)
 

thealiendad

macrumors member
Original poster
Jun 27, 2015
61
18
UK
just upgraded to beta version 17A330h and parallels is now starting without issue.

It still doesn't explain why the 'allow' functions showed momentarily and then disappeared. ;-)
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.