Almost a minute to Shut it Down ?

Discussion in 'MacBook Pro' started by TT1TT, May 27, 2012.

  1. TT1TT macrumors newbie

    TT1TT

    Joined:
    Oct 1, 2011
    #1
    Hello ,

    i have a macbook pro 2011 - 2.4GB - i7 - ram: 8 Gb - Mac OSx 10.7.4

    and if i want to Shut it Down or Sleep will take a minute !!

    all the application are closed , Even that it should force all the app to close if i need to, before on snow leopard i didn't have this problem ,

    any idea how i can solve it

    Thanks >
     
  2. angrydog macrumors member

    angrydog

    Joined:
    Dec 12, 2009
    #2
    Did you recently install your RAM? I had a similar problem where if I was shutting down, I would just get the scrolling circle for 30 seconds or so and this was after I installed some new RAM. It went away after a week or so. Yesterday I installed 8GB ram on my new Macbook and I also had the problem, but I did a PRAM reset and the 'scrolling/looping circle' problem went away after two reboots. Maybe it might be the RAM or it might not be.
     
  3. riptideMBP macrumors 6502

    Joined:
    May 29, 2011
    #3
    Try repairing disk permissions, and running a memory test. Also you could try turning off the sleepimage file, which is what prevents macs from "instantly" going to sleep/waking by providing redundancy in the event of power failure (but macbooks have batteries so...)
     
  4. TT1TT thread starter macrumors newbie

    TT1TT

    Joined:
    Oct 1, 2011
    #4
    I installed the ram 6 month ago and i am not sure if this is the problem!!
    and i don't remamber if i had that problem before

    what can i do to see if this is from the ram ?
     
  5. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #5
    It sounds like you may have an app that is having a problem shutting down. Before you shut down, close all apps, then Launch Activity Monitor and change "My Processes" at the top to "All Processes", then click on the CPU column heading once or twice, so the arrow points downward (highest values on top). Then keep an eye on that until it shuts down. If Mac OS X doesn't close AM first, you may be able to isolate what process is hanging.
     
  6. Donka macrumors 68020

    Donka

    Joined:
    May 3, 2011
    Location:
    Scotland
    #6
    Have you tried shutting down as soon as it has booted up? This should let you know if it is a system issue or an app issue. Do you have Time Machine running? If so, turn that off and see if there is a difference. Do you have many applications installed that run in the background?
    Have you checked in the console for the time of shut down to see what is being logged?
     
  7. TT1TT, May 28, 2012
    Last edited: May 28, 2012

    TT1TT thread starter macrumors newbie

    TT1TT

    Joined:
    Oct 1, 2011
    #7
    i did and everything seems normal :confused:


    no but i will try

    no

    all what i have :
    clipboard history
    totalfinder
    google drive
    geektool helper
    dropbox


    Thank you
     
  8. definitive macrumors 68000

    definitive

    Joined:
    Aug 4, 2008
    #8
    Try repairing disk permissions as stated earlier. It helped me out several times.
     
  9. Donka macrumors 68020

    Donka

    Joined:
    May 3, 2011
    Location:
    Scotland
    #9
    Any update on shutting down straight after starting up? Just curious if it remains the same?
     
  10. Prodo123 macrumors 68020

    Prodo123

    Joined:
    Nov 18, 2010
    #10
    I'd say Google Drive could be the culprit, as it's the most recent application out of the bunch you listed. None of the others have personally been problematic for me, as I keep Dropbox, SugarSync, gfxCardStatus, Little Snitch, smcFanControl, TotalFinder, iCal and Time Machine open at almost all times and still keep ~10 seconds for sleep time.
     
  11. lloyd709 macrumors 6502

    Joined:
    Jan 10, 2008
    #11
    Hope I might be able to help you - I had the same problem and it drove me MENTAL until I finally found the problem (from searching the web).

    You won't believe it but (for me anyway) it was that I had old print jobs still left in the print queue! Go to Pinter and Fax in system preferences. For each printer that you have set up there open the Print Queue and delete any print jobs still there. If you find any I bet that's your problem and your computer will go straight to sleep after you delete it/them.

    Hope this works for you.
     

Share This Page