Alright to disable Junk Filter in Mail?

Discussion in 'Mac Apps and Mac App Store' started by Jakerno, May 9, 2011.

  1. Jakerno macrumors member

    Joined:
    May 25, 2010
    #1
    I have my Mac Mail set up with my gmail account through IMAP. I'm assuming gmail will do all the spam filtering in Mail just like it does in the regular in-browser site. So, is it alright if I simply disable the "Junk Filtering" option?

    One more question, if I may. How would I got about deleting the contents of the spam folder in Mail without opening any of the letters? I can't seem to figure it out: http://d.pr/NQ6t

    thanks!
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    The Google instructions for setting up a GMail IMAP client suggest disabling any local spam filter and letting GMail do the work.
     
  3. Jakerno thread starter macrumors member

    Joined:
    May 25, 2010
    #3
    Cool, thanks. Any idea on how to go about deleting the spam through Mail?
     
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    Move it from the Inbox to the GMail Spam folder in your Mail app. That will tell GMail is is spam.
     
  5. Jakerno thread starter macrumors member

    Joined:
    May 25, 2010
    #5
    thanks.
     
  6. Jakerno thread starter macrumors member

    Joined:
    May 25, 2010
    #6
    Sorry to ask yet another question, but I came across this situation recently: http://d.pr/vL2E

    I opened my message in my inbox - i set the 'inbox' folder under Gmail to "use this mailbox for...sent" - yet the All Mail folder it seems is not reacting as if i opened my message. It's a bit of a nuisance to open the message, then click All Mail afterward.

    Any suggestions? thanks.
     
  7. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #7
    You really don't want to show "All Mail" Mail app because it causes all messages to show in the in box and in all mail, doubling the storage space required and slowing things down.

    Go to the Gmail web page and your settings then click the Labs tab and click enable Advanced IMAP controls then save changes. Then go to to Labels and uncheck All Mail. Then restart Mail app and you will no longer see the All Mail folder.
     
  8. Jakerno thread starter macrumors member

    Joined:
    May 25, 2010
    #8
    Awesome, worked very well. thanks.
     

Share This Page