alt+3 hash problem

Discussion in 'iMac' started by higgdpi, May 31, 2011.

  1. higgdpi macrumors newbie

    Joined:
    Mar 16, 2009
    #1
    Hello all :D
    try as i might i cannot work out how to get the hash key to show on my mac.
    I know it's supposed to be alt+3 and i've checked and checked all other keyboard shortcuts for conflicts and cannot find any. I've tried deleting the com.apple.keyboard prefs file but to no avail. I've also tried creating a new user on this mac... and whilst the hash character does appear, I need it to work on my administators login, not this extra user.

    Can ANYone help? I'm going nuts here... it's hard to code with no hash key... :confused:
     
  2. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #2
    Are you talking about this hash sign: # ??

    Try Shift + 3. That's how it is on the US Keyboard layout. If you have a different layout tell us what you are working with.
     
  3. higgdpi thread starter macrumors newbie

    Joined:
    Mar 16, 2009
    #3
    d'oh sorry, I'm in the UK so on a british layout (shift+3 gives me a £ sign)
    yep that's the sign :)
     
  4. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #4
    It appears to be on the tilde key on the right hand side.

    [​IMG]
     
  5. firestarter, May 31, 2011
    Last edited: May 31, 2011

    firestarter macrumors 603

    firestarter

    Joined:
    Dec 31, 2002
    Location:
    Green and pleasant land
    #5
    That isn't a UK Apple keyboard.

    On my UK Mac keyboard it's Alt-3 #.

    If you go to 'Keyboard' in system preferences, are your modifier keys set to what they should be? You could try restoring defaults.

    Are there any shortcuts set up that might affect this? Again, try restoring to default.

    Also try the 'Language and Text' control panel. Check that your Input Source is British.

    If none of that works, you could try using the Symbol substitution pane of 'Language & Text' to replace say '§' or '±' with '#'. Personally, I've never used '§' so it might be cool to reclaim that key anyway!!
     
  6. higgdpi thread starter macrumors newbie

    Joined:
    Mar 16, 2009
    #6
    i think that's a pc keyboard...
    my @ key is shift+2 and the tilde key is next to the z, the hash key in the diagram is \ (or | with shift) in my keyboard
     
  7. Phil A. Moderator

    Phil A.

    Staff Member

    Joined:
    Apr 2, 2006
    Location:
    Shropshire, UK
    #7
    Is this in OS X, Bootcamped Windows or a Virtual machine? Also, is it an Apple Keyboard (and is it bluetooth or wired?)

    What does alt-3 give you? On my iMac, it's definitely alt-3 for the # sign.

    If you switch to a US Keyboard (System preferences, language and text, Input Sources), it should swap around the # and £ (i.e. shift+3 gives you # and alt-3 gives you £): Does it?
     
  8. higgdpi thread starter macrumors newbie

    Joined:
    Mar 16, 2009
    #8
    Yes, OSX with wired apple keyboard. I tried a bluetooth keyboard and got the same results.
    hmm, interesting... switching to a US layout does give me the hash with shift+3 but now won't give me the pound sign with alt+3. I just get no input at all, no other character, no space, just as if i'm not pressing anything.
    sometimes in quarkxpress when i'm using the text cursor, it flickers between the text cursor and a hand icon until i press the alt key once and then it settles for being a text cursor...
    I guess worse case scenario i could keep switching keyboard layouts, but it's not ideal...
     
  9. Phil A. Moderator

    Phil A.

    Staff Member

    Joined:
    Apr 2, 2006
    Location:
    Shropshire, UK
    #9
    Have you tried both alt keys? Also, does alt+other keys give you anything?
    For example, alt-5 should give you ∞, alt-g is © and alt-v is √
     
  10. higgdpi, May 31, 2011
    Last edited by a moderator: May 31, 2011

    higgdpi thread starter macrumors newbie

    Joined:
    Mar 16, 2009
    #10
    hahah yes, i've tried all this already i'm afraid. restored to default and tried the replacement thing but that just doesn't work at all (none of them work)

    yes both keys are the same and all the other alt keys seem to be fine... except the one i actually need :rolleyes: ∞©√ç
     
  11. Phil A. Moderator

    Phil A.

    Staff Member

    Joined:
    Apr 2, 2006
    Location:
    Shropshire, UK
    #11
    Very weird!
    Is it possible that you've got a program running that's re-purposing (and therefore disabling) the alt-3 combination as a hotkey?
     
  12. higgdpi thread starter macrumors newbie

    Joined:
    Mar 16, 2009
    #12
    oops sorry ergdegdeg, I forgot about the multiquote thing :)

    Yeah, that was my first thought.. but I've tried looking for other programmes and conflicting shortcuts and can't find anything. I haven't installed anything new recently either. I'm baffled!
    I'm currently running Smultron, quark, photoshop, mail and firefox and none of those are conflicting, but then i can't get it to work straight after start up when i only have text edit running...
    As i say, it DOES work on a secondary user on this mac though... so it can't be fully fudged, it must be something i've done wrong somewhere...
     
  13. higgdpi thread starter macrumors newbie

    Joined:
    Mar 16, 2009
    #13
    Anyone any other ideas? :)
    I'm pretending I'm american at the moment so the hash key works but i can't type about money cos i now don't have a pound sign key ;)
     
  14. johanvee, Jul 1, 2011
    Last edited: Jul 1, 2011

    johanvee macrumors newbie

    Joined:
    Jul 1, 2011
    #14
    I had exactly the same problem, which I've now fixed after a couple of tries. I can't say whether it was just my last effort or a combination of all of these steps that did it.

    I tried resetting all keyboard & language settings to English (UK) or British. No change.
    I tried restarting the computer. No change.
    I tried logging in as another user. That worked.
    I logged back in as me. That didn't work.
    I then disabled Spaces. That worked!
    I re-enabled Spaces. It still worked!

    I think I might've set up a keyboard shortcut conflict when I was messing around with Spaces a few weeks ago. By resetting all shortcuts, disabling Spaces and then re-enabling it, it appears to have cured the problem.

    Good luck.
     
  15. dv1988 macrumors newbie

    Joined:
    Oct 26, 2013
    #15
    If you go to system preferences > Language and text > input sources. You should be able to add more types of keyboards, e.g. US layout keyboards etc etc whereby your hash key is shift + 3.
     

Share This Page