Alternate Store Issues

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Bijiont, Jun 15, 2011.

  1. Bijiont, Jun 15, 2011
    Last edited: Jun 16, 2011

    Bijiont macrumors newbie

    Joined:
    Sep 16, 2010
    #1
    Hello everyone,

    I seem to be having a slight issue when trying to access the Japanese iTunes store. I have two accounts created 1 for NA and another for JP as I travel so having those train schedule apps can be a life saver.

    I went to do an update on my JP account apps however when I login and try to perform an update it kicks me out stating that I must use the NA store. My JP account is tied to gmail, using a Japanese address and everything so I am not sure what the issue is. The updates have been performed over EDGE, 3G and Wifi all with the same results.

    I am on 4.3.3 with an iPhone 4 JB. The one thing which I haven't tried as of yet is to do the updates via my laptop and transfer them.

    Has anyone else ran into this issue? Is there any known issues which I wasn't able to find via google? I have never had a problem up until I updated to 4.3.3 which may be part of the problem.

    Apprecaite the help and sorry if this post comes across as noobish.

    EDIT
    After doing this process again I happen to notice something.

    When attempting to perform the update the pop-up asking for my password has my NA account listed when signed in under my JP account. I didn't happen to notice it before because it's just second nature now to type in the password and go on my way.

    EDIT 2
    iTunes also does not detect the new versions of the applications. Not sure what is happening as this must have just recently occurred.

    EDIT 3
    I tried to see if updates were available via iTunes however when I login to my JP account it does not pull the available updates. I am able to review my purchase history and I manually confirmed that updates are available. So far the only way I could pull the updates were via my iPad2 then sync and sync my phone up with the updated apps.

    It's very strange as again, I have not had any issues for almost a year now using the two accounts.

    Does no one else use two accounts or have seen this issue?
     
  2. Bijiont thread starter macrumors newbie

    Joined:
    Sep 16, 2010
    #2
    90 views and no replies I take that as I am on my own.

    Thanks anyways,
     
  3. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #3
  4. Bijiont thread starter macrumors newbie

    Joined:
    Sep 16, 2010
    #4
    Just wanted to give an update should anyone else see this issue.

    All accounts were activated on this machine and has been for a long time (2 years+ I think).

    The cause was actually iTunes go figure. For whatever reason iTunes would refuse to update from my JP store account even though it showed updates from it. After a clean reinstall of iTunes (removed prefs and everything) bang everything sync'd and responded as it should.

    I still have no idea what the root cause of it was but the re-install fixed it. This was a stable (recent) version of iTunes as well not beta on Mac.

    If you run into this and have tried everything else give iTune a re-install :)
     

Share This Page