Alu iMac graphics glitches

Discussion in 'iMac' started by iZac64, Jan 29, 2008.

  1. iZac64 macrumors newbie

    Joined:
    Jan 29, 2008
    #1
    Hi I usually browse these forums but never bothered to join because I didn't have any problems to discuss... until now, so this is my first post. I'm using an Aluminium iMac 20" 2.4Ghz which I bought around August/October and am having some issues with 3D graphics, for instance when I go into frontrow (in 10.4.11) and rotate the media icons, large triangular pieces which are blackish quickly flick on the icons (it is hard to get a screenshot of). Also when I am playing a game such as Warcraft III: The Frozen Throne it is really bad and little triangles constantly flicker on the screen when it is displaying 3D graphics, you can sort of see this in the screenshot below. I am hoping to fix this problem because it will be very annoying to play Starcraft 2 with little flashing triangles everywhere :mad:. Also i thought the iMAc graphics update 1.0 would fix this but sadly it didn't :(. I am thinking this might be something to do with the grahics card overheating and i tried smc fan control to cool it down but that didn't work so i'm thinking that the card might already be permanently damaged. Sorry for the long read but any help or suggestions on what to do would be great!;)

    PHP:
    http://img227.imageshack.us/my.php?image=picture1cv4.png
     
  2. Vis macrumors newbie

    Joined:
    Jul 21, 2005
    #2
    As a PC gamer and someone who overclocks everything, I can tell you exactly what it is. Yes, your video card is overheating. If you can't cool it down, you need to take it to an Apple store.
     
  3. shoulin333 macrumors 6502a

    Joined:
    Jun 26, 2007
    Location:
    California
    #3
    nah not a heat issue, just driver issue.

    Apple's drivers are far from perfect, that is not artifacting from heat, it would be more uniform. That is just layers or textures not rendering properly. the way to tell for sure that is an apple driver problem and not hardware is to install warcraft 3 on a windows partition in bootcamp and install the newest ATI catalist (spelling) drivers. I will be willing to bet it will render correctly.
     
  4. Vis macrumors newbie

    Joined:
    Jul 21, 2005
    #4
    Hm, well considering I still don't even own a Mac, you should probably listen to HIM and not me. Each time I've had problems it's heat related, but really, I don't know enough about it I guess (pc vs mac)
     
  5. iZac64 thread starter macrumors newbie

    Joined:
    Jan 29, 2008
    #5
    thanks!

    Ok I will try both of your suggestions thanks very much!
     
  6. nickf macrumors member

    Joined:
    Oct 2, 2007
    #6
    WC3 is a pretty old game now, so I'm not surprised you may be seeing some graphics glitches. I suspect this is a driver issue, as mentioned elsewhere.

    Do you have similar problems with more recent games?

    As for Front Row, I can't comment on that.
     

Share This Page