alu MacBook mic delay in Fusion

Discussion in 'MacBook' started by clayandthat, Jan 24, 2009.

  1. clayandthat macrumors newbie

    Joined:
    Jan 24, 2009
    #1
    On my uni network, Skype for Mac refuses to connect, which is probably due to the authenticated proxy. So instead, I hoped to virtualise Windows, as its version of Skype plays fine with the network.
    However, there is a horrifically long delay (usually 2-3 seconds) between talking at the mic and the computer acknowledging the signal.
    I've tried Fusion 2 and Parallels 4, running XP, Vista and the 7 beta, but still no luck. There is no delay when I run Vista under bootcamp, so I'm wondering whether its a driver issue, or maybe the Mac just can't process it fast enough.

    Any help from you guys would be appreciated!

    It's a 2.0Ghz model, if that helps
     
  2. kocoman macrumors regular

    Joined:
    Dec 26, 2007
    #2
    I also have the same problem, but I am using parallels and dragon naturally speaking on a dual core system (with single core or to dual core enabled in the virtual machine), is there any way to test for the delay itself within Mac?

    Maybe it's related to this:

    If you use audacity, you may be accidentally applying a 'post-process' effect to the sound source, through your sound-card which might be responsible for the delay, the third-party software may seem more responsive simply because it's bypassing the effect? Check that all effects are off. Some effects are 'post-processed' and some are 'real-time'. The post-process effects use a buffer (delay) which might be adjustable using the control panel software for your Audacity. Of course it may be something else completely - if you've installed third party software, I would recommend removing their drivers and only using the original sound-card drivers (device manager), I had a 'nightmare' with a rogue 'busy bee' audio driver that snuck onto my system as the default driver after I installed a trial vocal remover.

    But in our case, maybe it's related to the conversion of frequency or bitrate.

    For example: the input from Mac is 48 kilohertz, that input is converted into 44 kilohertz for windows, and this is where the delay is from??

    Too bad parallels and fusion is not open source, otherwise somebody else could easily fix it.
     

Share This Page