Aluminium 15" Powerbook won't turn on

Discussion in 'PowerPC Macs' started by trickytree1974, Aug 28, 2008.

  1. trickytree1974 macrumors newbie

    Dec 10, 2007
    Hi all

    I'm trying to help a friend out with their Aluminium 15" Powerbook, which he describes as 'dead'.

    I have it here, and it seems ... dead.

    Here's maybe why- he dropped it on the corner where the power cable goes, with the cable in, which bent the pin on the cable.

    He has bought a new cable, and a new battery, but nothing doing on any combination, even without a battery in. He says it worked a few times when he got the new battery, but once it used up all the charge it came with, it wouldn't recharge ...

    I have tried the PMU reset and still no joy.

    The amber light comes on when the new cable is plugged in, with either of the batteries or none at all.

    Any help would be greatly appreciated!!
  2. TEG macrumors 604


    Jan 21, 2002
    Langley, Washington
    It sounds like he broke the DC-DC board (that converts the DC Power in to the different voltages needed for the computer).

    An Apple Store may be able to replace it, but they may replace the whole motherboard.

    If you can charge up the batteries on another PowerBook, then it should work fine, at least if you need to get the data off before it is repaired.

  3. soberbrain macrumors 65816


    May 9, 2008
    Ouch. I dropped my PowerBook like that too. But luckily my it still functions as a desktop machine.

    If the new power cord isn't working. It sounds like a bad hardware problem.

    The only resolution maybe to have it fixed, fix it yourself, or get a new computer.

    Repairs maybe costly, though.
  4. trickytree1974 thread starter macrumors newbie

    Dec 10, 2007
    Thanks for the replies guys, sounds pretty expensive/grim for him though!!

Share This Page