Aluminum MacBook battery stuck at 99%

Discussion in 'MacBook' started by KheeseKake, Feb 5, 2009.

  1. KheeseKake macrumors newbie

    Joined:
    Feb 26, 2007
    #1
    Hi there,

    A few weeks back I bought a new 2.4 GHz Aluminum MacBook and it's been going great so far, however I've recently noticed that I seem to be having a problem with charging the battery. Whenever I plug in the charger and let it charge the battery it will always stop when it gets to 99% and when I open the menu on the menu bar icon it says "Battery is finishing charge." I understand that it is normal for this to happen for quite a long time when charging the battery sometimes, however I can have it saying this when I go to bed at night and wake up in the morning and it'll still be doing this. The orange light on the magsafe adaptor just stays lit and when I disconnect it the battery level changes to 100% but when plugging it back in, the light will go green for a few seconds and then turn orange and the level goes back to 99%. Any help on this would be greatly appreciated :) and sorry if there are already posts on this topic however I wasn't able to find anything myself.

    Thanks,
    KheeseKake
     
  2. netnothing macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #2
    Do you let the battery get below 93-95% before plugging it back in? The Magsafe will not charge the battery unless it is below 93-95% charge.

    http://support.apple.com/kb/TS1909

    -Kevin
     
  3. Jinsou macrumors regular

    Jinsou

    Joined:
    Nov 18, 2007
    #3
    Yes, this is perfectly normal... they do this to protect the battery..
     
  4. KheeseKake thread starter macrumors newbie

    Joined:
    Feb 26, 2007
    #4
    Yes, the battery has definitely been below 90%. In fact I forgot to mention that I tried calibrating the battery the other day to see if this would fix the issue, so I let it run completely down to 0% until it went to sleep and then waited for more than 5 hours and then plugged it back in and let it charge but when it got back up to 99% it continued to do the same thing and the magsafe light would never change to green even after several hours of it saying "Battery is finishing charge."

    KheeseKake
     
  5. netnothing macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #5
    While I have seen it take a while to "finish charge", I've never seen it never complete.

    Maybe a trip to the Genius Bar to see if they have any ideas? I guess it could be a battery issue, since the orange light on the magsafe never goes off. To me that would make me worry that it's sending the small charge to the battery all night.

    Have you tried Coconut Battery to check the stats?
    http://www.coconut-flavour.com/coconutbattery/

    -Kevin
     
  6. KheeseKake thread starter macrumors newbie

    Joined:
    Feb 26, 2007
    #6
    I just took a look at coconut battery now and attached a screenshot of what it's currently showing...

    I'm guessing the health in here doesn't seem too good considering my old first gen 17" MacBook Pro isn't even this low and it's been through 150+ cycles. It also seems strange that coconut Battery is showing that the battery is 100% charged but not in the menu bar.
     

    Attached Files:

  7. netnothing macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #7
    Yeah, that doesn't look too good for a battery that is only a few weeks old.

    I'm pretty sure the 4100 mAh is the correct base number for the Alu. MacBooks. Although, usually brand new batteries rate even higher than the base rate.

    I'd take it into Apple...they should give you a new battery.

    -Kevin
     
  8. couto27 macrumors 6502

    Joined:
    Nov 10, 2008
    Location:
    lisboa,portugal
    #8
    i have a new aluminium macbook pro 2,53.
    to me happen the same thing 99% and apperars the green light at 99%.
    i let discharge completly for 6 hours , than recharge again for 5 more 5 hours, and it sotps at 99% and the green light appear.
    note my battery as only 5 cicles.
    i install coconut
    my original charging was 4600 mha
    and now is only 4452 mha

    but 2 days before this happen my charge was 4638 mha 100%
     
  9. couto27 macrumors 6502

    Joined:
    Nov 10, 2008
    Location:
    lisboa,portugal
    #9
    it 100% now

    well after my last post , now the battery charges 100% and appers green, but coconut shows

    maximum battery charge 96%

    original 4600 mha
    current capacity 4494 mha
     
  10. oneEG6 macrumors member

    Joined:
    Dec 29, 2008
    #10
    What does system profiler show for the same information? If the light is green and the numbers match up, I would tend to believe system profiler before that app.

    You have the firmware updates right? This was a "known issue" of sorts with the new aluminum Macs, my buddy's new MBP was doing this and 2 new batteries still did not help the issue. The updates did fix it for him, that and a good calibrating the battery seemed to solve it.
     
  11. couto27 macrumors 6502

    Joined:
    Nov 10, 2008
    Location:
    lisboa,portugal
    #11
    image

    im trying to calibrate again

    where a image of coconut
     

    Attached Files:

  12. KheeseKake thread starter macrumors newbie

    Joined:
    Feb 26, 2007
    #12
    Thanks for all your help Kevin. I'll be sure to take it into Apple, as I was able to test my battery earlier in a friend's 2.0 GHz Aluminum MacBook and it did the exact same thing. I also tried their battery in mine and it was fine so it seems like it's definitely a problem with the battery and thankfully not the machine/magsafe.

    KheeseKake
     

Share This Page