Aluminum Macbook Magsafe Adapter Problem

povsicf

macrumors member
Original poster
Mar 18, 2009
49
0
Hey I have a unibody macbook 13" The weirdest thing in the world is happening. When I plug in my magsafe adapter to it the green light nor the yellow light goes on, in the battery status bar there is a small plug icon showing that its plugged in but doesn't look like its charging. I try plugging it in in my living room and the same thing. I then tried plugging it in my dining room and it then lit up green as it was charging and in the battery indicator there was a picture of like a little lightning bolt showing it was charging. So I'm a little lost. I usually use it as my desktop in my room so I would prefer to let it charge in my room. Any ideas on what this could be????? I'm lost I tried restarting it and all kinds of stuff. Don't know what it could be. I'm open to any ideas. Thanks guys.
 

povsicf

macrumors member
Original poster
Mar 18, 2009
49
0
Just a thought, but are you sure that the outlet that you were using isn't the problem?
I thought at first that may be my problem, but I have other things plugged into the wall and the surge protector and they are working fine. Right now the charger is plugged right into the wall.
 

bozz2006

macrumors 68030
Aug 24, 2007
2,530
0
Minnesota
OK. Have you tried unplugging one of the items out of the outlet that you know for sure works with other stuff, then plugged the charger into that specific outlet? Seems silly, but I had been assuming all week that my air purifier was shot. It wouldn't start, and the lamp that I have plugged into the same outlet did work. So you'd assume the outlet is fine, right? Nope. For some reason, in my apartment, those two outlets in that jack were connected to different circuits. the air purifier worked fine when plugged into the lamp outlet.
 

povsicf

macrumors member
Original poster
Mar 18, 2009
49
0
OK. Have you tried unplugging one of the items out of the outlet that you know for sure works with other stuff, then plugged the charger into that specific outlet? Seems silly, but I had been assuming all week that my air purifier was shot. It wouldn't start, and the lamp that I have plugged into the same outlet did work. So you'd assume the outlet is fine, right? Nope. For some reason, in my apartment, those two outlets in that jack were connected to different circuits. the air purifier worked fine when plugged into the lamp outlet.
Yeah its really weird I did try that. Now for the hell of it I tried putting it back to where it charged earlier and same thing, nothing no green light no yellow light nothing. No charge. Shows its plugged in but no charge.
 

bozz2006

macrumors 68030
Aug 24, 2007
2,530
0
Minnesota
Do you have any friends who own macbooks? Maybe try their chargers, to see if your charger is the problem.
 

Similar threads

  • hawkeyefxr
3
Replies
3
Views
248
  • supertiffany
4
Replies
4
Views
366
  • jcmc
3
Replies
3
Views
353
Replies
0
Views
217
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.