Aluminum Macbook Trackpad problems

Discussion in 'MacBook' started by macandipodfan, Feb 10, 2010.

  1. macandipodfan macrumors member

    Joined:
    Mar 30, 2008
    #1
    I bought a used 2GHZ Aluminum MacBook off eBay.
    For some reason, when I click on the lower right corner of the trackpad, it presses down and sticks in that position. The left side of the trackpad clicks fine.
    The computer appears to have about 2 months of warranty left, but I am wondering if there's anything to try on it before I take it in.
     
  2. MarkCooz macrumors 6502a

    Joined:
    Jul 12, 2009
    Location:
    California
    #2
    Just send in the computer, If it has warranty no need for you to mess with it even more. Also buy AppleCare when you're taking it in so you'll have 3 more years of warranty
     
  3. Disc Golfer macrumors 6502a

    Joined:
    Dec 17, 2009
    #3
    Macbook applecare extends warranty three years from the computer's original date of purchase; if OP gets applecare now they'll have two years (and two months) of warranty remaining.
     
  4. macandipodfan thread starter macrumors member

    Joined:
    Mar 30, 2008
    #4
    I suppose I'll just take it in.

    I've got an AppleCare box laying around, so I might register that if there's nothing else wrong with it.
     
  5. Timmbo macrumors regular

    Joined:
    Oct 14, 2008
    Location:
    England
    #5
    This isn sort of related, so I thought I'd mention it here. I'm having some problems with the trackpad on my Unibody Alu Macbook too. My clicks aren't registering all the time, sometimes I'll have to attempt to click at least 3-4 times before it is recognised. USB mice still work perfectly.

    Anyone else having similar problems?
     
  6. IangussI macrumors newbie

    Joined:
    Feb 13, 2010
    #6
    use the waranty. or alternativly get a mouse. until then i reccomend disabling the trackpad and using mouse keys (press the option key 5 times). if you are using snow leopard use the mouse keys to get to system prefrences>Universal Access>Mouse and Trackpad and check the "ignore trackpad when mouse is present" box.

    Hope this helps!
     
  7. Ljw1976 macrumors member

    Joined:
    Oct 12, 2008
    #7
    had similar problems..but i just ended up blowing down the side of the gaps near the faulty area..and u know what..it works again..


    i know the frustration u lot are going through..but have a try..as it can gain a result...
     

Share This Page