Aluminum MacBook trackpad won't compress

Discussion in 'MacBook' started by skylarbrenden, Jul 30, 2013.

  1. skylarbrenden macrumors member

    Joined:
    Jul 14, 2013
    #1
    Well my 2008 Aluminum MacBook won't compress anymore. It was clicking a little weird, and I did a google search and it said that on these models, many many many people has this problem, and that it's a loose screw.

    So I went to tighten the screw 1/8 of a rotation, like all of the sites say, and when I did, I checked the trackpad an it no longer compresses. I've tried putting it back to the original rotation of the screw, and it didn't work. It's still wont click in

    The left and right sides will click in if you click really really hard. But the middle won't.

    One thing I noticed, is that the screw is like not in the hole correctly. The screw moved around if you put any pressure on it.

    Have I ruined it? Anything suggestions?

    By the way, I also read that the batteries have expanded and messed the trackpad case up. Like knocked it out of alignment. But the battery looks fine. It is, however, reaching the end of its life (says replace soon)
     
  2. madmacfan macrumors 6502

    Joined:
    Feb 19, 2012
    Location:
    London, United Kingdom
    #2
    From what you have described, It sounds like the battery is pushing the trackpad out of alignment, hence you not being able to click, which is a common problem with unibody MacBooks. My advice would be to remove the battery, undo the screw, tighten it back up and open up the macbook to check the adjustment (Do not put the battery back in), if this works, then you know for sure it is the battery and as it's nearing the end of it's life, now would be a good time to replace it.
     
  3. skylarbrenden thread starter macrumors member

    Joined:
    Jul 14, 2013
    #3
    That's what I suspect. The Mac says the battery needs to be replaced soon. I took the battery out and it still doesn't work like it should. I ordered the tri-wing screw driver so I'm just waiting for that to get here and ill see what happens
     
  4. Lord Xeb macrumors member

    Joined:
    Jun 17, 2010
    Location:
    Someplace in the Nor' East
    #4
    If you use a small enough flathead, you can adjust the screw and you don't need the tri-lobe screw drivers. Little trick ;)

    If adjusting the screw does not solve the problem, then the trackpad will require replacement.
     

Share This Page