Am I overloading my FireWire bus?

Discussion in 'Mac Accessories' started by hob, Aug 5, 2006.

  1. hob macrumors 68020


    Oct 4, 2003
    London, UK
    Those of you that know me may know I'm not brand new to macs, and may recall I have a pretty new intel iMac.

    Noticed something odd though

    The first issue is that my Lacie Big Disk has never booted off firewire 400. It's been this way since I got it, and since I got it second hand there's nothing I can do about it!

    So this was never a problem whilst I had my PowerMac G5 - I'd use FW800, and also daisy chain my other Lacie External through FW800.

    Then I got the iMac having sold the powermac, and the only thing missing was the FW800 port.

    So I use the little lacie disk's FW400, and then daisy chain through FW800 like before.

    So far, so good.

    But since I got the iMac I stopped using the externals so much. They're quite noisy, as was the PowerMac - but the iMac is so quiet I preferred to have them off most of the time.

    So today I plugged them in for the first time for a while.

    They wouldn't mount straight away, so I left them.


    So i unplugged the power and disconnected the drives from each other, and just tried plugging the little disk in.


    Tried again.

    It mounted - woohoo!

    Re-established the daisy chain, fine.

    Then later on I plugged in my 3G iPod - it's FW400.

    It mounted in iTunes, but then in the finder, it was mounted. I checked to see if Disk Mode was enabled - it was.

    Then I notice Finder is beachballing.

    I unplug the ipod, Finder resumes.

    I shut down, plug in the iPod, and start up again.

    The iPod has "charging" on the screen, but it does not mount at all.

    So then I disconnect the other FW400 cable, which leads to my two lacie drives, and surprise surprise, the iPod mounts.

    So what's going on? Can the iMac not handle all 3 devices at once?! :confused: :eek:
  2. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    I'm not quite clear if your "little" LaCie is bus powered or not; if it is, you could well be overloading things by plugging it and the iPod in at the same time... but that's not the symptom I'd expect to see.

    It sounds more like one of the devices just isn't playing well with others--you SHOULD (in theory) be able to chain 63 devices on a single FW bus, but if something is misbehaving, it's quite possible that plugging it in along with something else could cause symptoms like that.
  3. hob thread starter macrumors 68020


    Oct 4, 2003
    London, UK
    Sorry, that wasn't the most coherent post I'd ever written...

    Both of the lacies are powered - they're basically the same thing, just the big disk has 2 drives instead of one!

    I'll keep poking at it...
  4. Super Macho Man macrumors 6502a

    Super Macho Man

    Jul 24, 2006
    Hollywood, CA
    Firewire can be quirky like this. I have 5 devices on one FW400 bus. I have them chained up like this: Mac -> EyeTV -> Oxford 911 drive -> audio interface -> DVD burner -> DV cam. Sometimes the audio interface (apparently) will "freeze" the bus. I've tried hooking them up in alternate order and when I had the DVD burner closer to the Mac, the whole chain wouldn't work. And so on and so forth... So I suspect your problem is a cheap Taiwanese FW chipset somewhere in the chain. It could be in one or both of the Lacie drives. Oxford chipsets are known to be reliable, but are also the most expensive, and Lacie doesn't make its own chipsets, or drives, which means they may have gone the cheap route to increase margins. Maybe see if you can find out what chipsets your drives use. If it says Oxford then your problem is probably something else, if it says Prolific or Genesys (known crap chipsets) then you likely know what your problem is.
  5. magid macrumors 6502


    Jan 6, 2003
    I think I read somewhere that the new intel macs only support os booting through usb2 not firewire anymore. I could be wrong though.
  6. hob thread starter macrumors 68020


    Oct 4, 2003
    London, UK
    I'm not booting from the hard disks!
  7. hal0n macrumors regular

    Dec 27, 2004
    i had a similar problem with my collection of firewire devices. I have 3 hard drives 2 dv sources (up to 4 depending on how painfully old the format is) and an ipod that get plugged in regularly.. I solved my issues with a 40$ fw hub from compusa.

    i still run 2 of my hard drives daisy-chain on the fw800 into the fw400 of the other drive. I'm too cheap to buy more cables, but it works just fine.
  8. LeeTom macrumors 68000


    May 31, 2004
    I had a problem with a Genesys chipset external drive... It would randomly decide when it wanted to mount... I put the drive in an Oxford 911 chipset case, and now it works perfectly every time.
  9. kyleaa macrumors regular

    Jun 20, 2006
    I know that it is not really in the scope of this post, since the OP isn't booting off an external drive, but I believe what you read somewhere was that the new iPods won't boot off firewire. The Intel iMacs definitely will boot off firewire, but you may run into problems because the EFI in the Intel iMac requires a different partition scheme than PowerPC computers did, therefore, a PowerPC bootable drive will not be bootable under Intel, and vice versa.

Share This Page