Discussion in 'MacBook Pro' started by FalcorTheDog, Dec 9, 2006.

  1. FalcorTheDog macrumors member

    Jun 17, 2005
    So my Powerbook froze a few weeks ago. I gave it a few minutes, but was eventually forced to manually restart. All I got was a blank white screen on reboot. Since then I've tried just about anything I can think of to at least get my data off of it. Here are the major symptoms:

    -Initially got blank white screen, now I get folder/question mark on bootup
    -When booting from CD, cannot see any drive to install OS X onto, however in Disk Utility, it does "see" the hard drive, but cannot perform any first aid or repairs on it. Seems like it's not mounted.
    -Can't boot into target disk mode
    -Zapped PRAM... nothing.
    -Disk Warrior couldn't find my drive, although it could tell me that it's SMART Status was "O.K."
    -Even tried booting from another Powerbook in target disk mode, which worked, but my hard drive still wouldn't mount.
    -Took apart case and checked hard drive cable connection... looked fine physically (warranty is already a few months out of date)

    In Disk Utility it does give me the option of "Erase Disk", which I'm about to give up and try. Any other ideas before I concede? I took it to the Apple store and they told me it would cost at least $300 to repair and said it was unlikely they'd get the data off of it. I can install a new hard drive myself for much cheaper, but would really like to get some of that data off of it first. Most important things are backed up, but sure would be nice to not lose everything else. I have had so many problems with this powerbook, and this has been my first experience with a mac. I hate to attribute this to apple and am still thinking I just had some real back luck with this machine. Any help would be greatly appreciated. Thanks in advance.
  2. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    Mate, Target Disk Mode was probably your best bet for getting the data back. I guess you could try cooling the PowerBook down (shut it off, put it in an airtight bag in the fridge or something) before attempting it again. This assumes it is the hard drive that is having the issues. Otherwise, I'd just go ahead and erase it. Sorry mate. FWIW, not all Macs are like this. You've just been unlucky. :(
  3. orangemacapple macrumors 6502

    Sep 1, 2006
    i would pop in a new HD, put the old HD in an external case and see what i could do with it then.
    good luck
  4. FalcorTheDog thread starter macrumors member

    Jun 17, 2005
  5. KD7IWP macrumors 6502a


    Mar 8, 2004
    American living in Canada
    Something like this. It's just a case you can place a laptop hard drive in and then hook it up to your computer with Firewire or USB to see if you can mount it, separately from your system.
  6. FalcorTheDog thread starter macrumors member

    Jun 17, 2005
    So after a few miracles, I have had some partial success with the external mounting idea. So I bought one of these:

    I took apart my PowerBook and yanked the hard drive out and hooked it up with the external converter above. I still can't boot off the drive, but the system CAN successfully mount and recognize the drive. So I was able to boot Ubuntu, a Linux OS that can be boot into entirely from the CD and the hard drive was recognized and I could browse my files! The problem is, it says I do not have the "permissions necessary" to view the contents of my user folders (probably because the account is password protected), which is the data I'm trying to backup in the first place. I'm so close, any last ideas? My next idea is to get an external firewire drive and install OS X onto it, boot from that and then try to transfer my files to the firewire drive, but will I run into the same permissions problem? Any help is greatly appreciated. Thanks!

Share This Page