Am I the only one having this iMessage problem?

Discussion in 'iOS 7' started by Itreepuncher, Jul 18, 2013.

  1. Itreepuncher macrumors newbie

    Joined:
    Jul 18, 2013
    #1
    Hey guys. So I got iOS 7 on my phone and I was texting when one of my friends asked why I'm texting from my email. I went to my message settings and I'm set to receive at my number and my email, but I start new conversations with my email only. The same goes for FaceTime. Any solutions/similar issues?
     
  2. HarryAinslie macrumors regular

    HarryAinslie

    Joined:
    Feb 2, 2011
    Location:
    Doncaster, England, UK
    #2
    Settings - Messages - Send & Receive - Start new conversations from (Select your mobile number)
     
  3. Unhyper macrumors regular

    Unhyper

    Joined:
    Apr 7, 2010
    Location:
    Finland
    #3
    So in Settings/Messages/Send&Receive/ in the bottom of the page under "start convos with..." you have your phone selected as the default?
     
  4. Itreepuncher thread starter macrumors newbie

    Joined:
    Jul 18, 2013
    #4
    I stated that my phone number only shows in the "Receive" section and is frayed out, but not in the "Start new conversations" section. I tried resetting network settings however since my contacts are backed up on iCloud I may just erase all content and restore factory settings
     
  5. HarryAinslie macrumors regular

    HarryAinslie

    Joined:
    Feb 2, 2011
    Location:
    Doncaster, England, UK
    #5
    Hmm :confused: that's weird for it not to be on your phone. iPad etc i could understand but not iPhone.

    On the iPad/iPod/Mac, if you switch iMessage off then back on it refreshes it and works again.

    Maybe try this rather than restoring just now.
     
  6. Unhyper macrumors regular

    Unhyper

    Joined:
    Apr 7, 2010
    Location:
    Finland
    #6
    My apologies, I missed that.

    Did you try, on the Send & Receive page, clicking on your Apple ID (top of the page), signing out, and signing back in?
     
  7. Itreepuncher thread starter macrumors newbie

    Joined:
    Jul 18, 2013
    #7
    Yes I did that, it gave me options of which addresses to send and receive from. My phone was checked and grayed out, so unselected my email and it said no addresses

    ----------

    I tried this and it didn't work. This is pretty frustrating
     
  8. Unhyper macrumors regular

    Unhyper

    Joined:
    Apr 7, 2010
    Location:
    Finland
    #8
    Did you also sign out your Apple ID under FaceTime as well? Basing that on an old Apple iPad help article, so grasping at straws here.

    You may be right that a reinstall may be easiest way to go. Was it an update and/or restore from backup, by any chance? I've had all kinds of weird issues when I update over the existing system or reinstall but don't set up as a new phone.
     
  9. Itreepuncher thread starter macrumors newbie

    Joined:
    Jul 18, 2013
    #9
    I restored from my iCloud backup. I'm going to try erasing all content and settings. I did indeed sign out of FaceTime as well
     
  10. Shishu macrumors member

    Joined:
    Jul 29, 2011
    #10
    I had similar problem. Disabling iMessages on all my devices and then enabling them solved the issue. You should start with the phone when you start enabling iMessages again.
     
  11. Itreepuncher thread starter macrumors newbie

    Joined:
    Jul 18, 2013
    #11
    Restoring my phone didn't work. I believe I only have my phone connected. Actually when I restored my phone the number doesn't show up in the send or receive area at all

    ----------

    Ah so somehow when I was going to try signing out after restoring, it fixed itself. Oh well. Thanks for attempting to help guys
     
  12. HarryAinslie macrumors regular

    HarryAinslie

    Joined:
    Feb 2, 2011
    Location:
    Doncaster, England, UK
    #12
    I'm not trying to insult your intelligence, have you tried calling the phone just to ensure the Sim is working?

    It's bizarre the phone doesn't know it's own number.
     
  13. Itreepuncher thread starter macrumors newbie

    Joined:
    Jul 18, 2013
    #13
    My intelligence? I've been programming since I was 7. There's a reason I was stumped. And not to insult your intelligence, but my iPhone is CDMA. Don't you think I would've tried everythig before posting?
     
  14. HarryAinslie macrumors regular

    HarryAinslie

    Joined:
    Feb 2, 2011
    Location:
    Doncaster, England, UK
    #14
    You obviously took what i said completely the wrong way! I thought the issue may have been with the Sim card, so didn't want to say "Is your sim installed" as i guessed you're a lot wiser than that.

    I guess i tried to word it differently and explain that i wasn't being rude, insulting etc but is your sim card working.

    Sorry if i offended you! It wasn't intentional
     
  15. firewater macrumors regular

    Joined:
    May 22, 2009
    Location:
    San Francisco, CA
    #15
    You need to restored your iphone back to ios6 and restore it as new & then installed ios7 to correct imessage & facetime. That work for me

    :)
     

Share This Page