am i the only one....

Discussion in 'Jailbreaks and iOS Hacks' started by troyhouse, Aug 7, 2010.

  1. troyhouse macrumors 6502

    Joined:
    Jan 3, 2010
    #1
    i have 3gs on 3.1.2 jb/ul and using it on tmo... i have still not upgraded to ios4.0 and not see any big benefit of doing it...

    am i the only one on this configuration or should i upgrade to ios4.0 and jb/ul, what do you guys think, is the new jb/ul stable enough,

    i do not have 3.1.2 shsh saved, so i really want to be sure before upgrading to os4.0 and then jb/ul...
     
  2. moussekateer macrumors 6502a

    moussekateer

    Joined:
    May 12, 2009
    #2
    I like 4.0 over 3.1.3 not just for folders, but for threaded emails. Couldn't live without it now. The new jailbreak works fine. Whether or not your favourite jailbreak programs have been updated for 4.0 is another matter.
     
  3. troyhouse thread starter macrumors 6502

    Joined:
    Jan 3, 2010
    #4
    to think of it, i should upgrade jb and ul before apple blocks it...

    by the way, i dont have att sim

    so what would be the best process, is following correct?

    1. backup phone
    2. upgrade from itunes
    3. goto jailbreakme.com, jb and ul it

    main thing is, hopefully my wifi works and i dont have to activate it, as i dont have att sim...

    am i missing anything, and any pointers?
     
  4. outz macrumors 6502

    Joined:
    Jul 17, 2007
    #5
    Don't forget ultrasnow for the unlocking.

    Someone else might be able to chime in regarding the activation... I've always had an AT&T sim.
     
  5. moussekateer macrumors 6502a

    moussekateer

    Joined:
    May 12, 2009
    #6
    Now hold up a minute there. The new jailbreak is a userland jailbreak and you need to be activated.

    I don't have much experience with the 3GS's situation so perhaps someone else can chime in about custom firmwares
     
  6. troyhouse thread starter macrumors 6502

    Joined:
    Jan 3, 2010
    #7
    its already activated it, and i am using it with tmobile. so what happens when i upgrade to 4.0.1, will i have to activate again?
     
  7. moussekateer macrumors 6502a

    moussekateer

    Joined:
    May 12, 2009
    #8
    Yes. It needs to be activated every time you restore.
     
  8. troyhouse thread starter macrumors 6502

    Joined:
    Jan 3, 2010
    #9
    i have an att sim card, but the account is canceled, will that still work?
     
  9. moussekateer macrumors 6502a

    moussekateer

    Joined:
    May 12, 2009
    #10
    I'm not sure but I doubt it? I don't have any experience with the American carriers.
     
  10. jplusc macrumors 6502a

    Joined:
    Jul 5, 2010
    #11
    I restored a jailbroken 3GS from 3.1.3 to 4.0 today. Set it up as a new phone and did not activate it (it had my old AT&T sim after upgrading to the iPhone 4). After the restore it said it was not activated. From there I put it in airplane mode, turned on wifi, jailbroke the phone with jailbreakme.com. From there I did the cydia updates via wifi. After that I threw in my brothers t-mobile pre-paid sim, left the phone in airplane mode and turned off 3G data, then went and installed ultrasn0w from cydia. After the reboot the phone was up and running on t-mobile (I believe I had to turn off airplane mode after the reboot). So I don't think the phone needs to be activated.
     
  11. troyhouse thread starter macrumors 6502

    Joined:
    Jan 3, 2010
    #12
    thanks for the reply, did the old att sim had an active account, or it was just defunct one...
     
  12. jplusc macrumors 6502a

    Joined:
    Jul 5, 2010
    #13
    Defunct since my iP4 was activated on that line with the new micro sim.
     
  13. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #14
    Yes, any AT&T simcard will work even old inactive ones.
    The only thing with 4.0 and Tmobile is that everyone is still having a hard time getting MMS to work.
    Data,texts and calls shouldnt be a problem though.
     
  14. troyhouse thread starter macrumors 6502

    Joined:
    Jan 3, 2010
    #15
    thanks a lot... so here is the process, please let me know if i missed out anything, i would hate to be without phone.

    0. backups taken, photos/videos copied
    1. insert att defunct sim card
    2. upgrade to 4.0.1
    3. enable airplane, enable wifi
    4. goto jailbreakme.com, and jb it
    5. goto cydia, make my life easier
    6. add repo, and ul it

    hope this is how it works... wish me luck.. gonna try it in 10-15 mins.
     
  15. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #16
    Yes, the repo is already preinstalled.
    You just gotta go to cydia/manage/sources and look for the ultrasnow repo and then install ultrasnow.
    The rest looks good.
    Good luck.
     
  16. alectheking macrumors 6502a

    Joined:
    Mar 9, 2010
    #17
    Yuuuuup, git r' done
     
  17. troyhouse thread starter macrumors 6502

    Joined:
    Jan 3, 2010
    #18
    its asking em to upgrade to itunes, 9.2.1, is it safe?
     
  18. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
  19. troyhouse thread starter macrumors 6502

    Joined:
    Jan 3, 2010
    #20
    oh itunes upgrade is painfully slow, should i take backup of my iphone again after itunes upgrade. i am not going to use it in any case.
     
  20. troyhouse thread starter macrumors 6502

    Joined:
    Jan 3, 2010
    #21
    its going thru backup process... will push notifications work with non-working att sim card and with this jb/ul?
     
  21. mustnotsleep macrumors 6502

    Joined:
    Apr 3, 2010
    #22
    3.1.3 is better than 4.0 by quite a bit. dont know why you want to upgrade so badly.
     
  22. troyhouse thread starter macrumors 6502

    Joined:
    Jan 3, 2010
    #23
    at some point i will have to upgrade, and what happens apple fixes this pdf jailbreak hack and now i will be 2 revisions behind. with this upgrade atleast i will get to 4.0 or else i will have to wait for long time.
     
  23. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #24
    3.1.3 is better for a 3G but for a 3GS the additional features, multitasking plus many others and app compatibility with 4.x+ is well worth the update.
    How is 3.1.3 better and why for a 3GS?
     
  24. troyhouse thread starter macrumors 6502

    Joined:
    Jan 3, 2010
    #25
    can you believe, backup is still in progress
    i am getting impatient, should i just cancel the backup process.....
     

Share This Page