AM/PM Glitch?

Discussion in 'Mac OS X Lion (10.7)' started by AmbiguousNinja, Sep 28, 2011.

  1. AmbiguousNinja macrumors regular

    AmbiguousNinja

    Joined:
    Jun 15, 2011
    #1
    Hey everyone, every time I use a calendar app (iCal, iStudiez Pro) and I add an event, the program never lets me change the AM/PM thingy. Is this a bug or did my preferences screw up somewhere?
     
  2. tjb1 macrumors 68000

    Joined:
    Aug 26, 2010
    Location:
    Pennsylvania, USA
    #2
    Did you type the time in like this?? Also, if you click the event you can edit the time by clicking on it.

    When I typed "Move at 8am on Saturday", that is the event I got, when I click on the event that is the dialogue I get and then you can click on time and whatever to edit it.
     

    Attached Files:

  3. AmbiguousNinja thread starter macrumors regular

    AmbiguousNinja

    Joined:
    Jun 15, 2011
    #3
    No, I actually go in and edit the time but I only see "PM," I can't switch it to "AM"
     
  4. tjb1 macrumors 68000

    Joined:
    Aug 26, 2010
    Location:
    Pennsylvania, USA
    #4
    If you click on "PM" and hit "A" it will switch to "AM".
     
  5. AmbiguousNinja thread starter macrumors regular

    AmbiguousNinja

    Joined:
    Jun 15, 2011
    #5
    Is it supposed to highlight first? Because it doesn't even highlight when I click it.
     
  6. tjb1 macrumors 68000

    Joined:
    Aug 26, 2010
    Location:
    Pennsylvania, USA
    #6
    Does it look like this when you are trying? You need to click edit to get into this dialogue.
     

    Attached Files:

  7. AmbiguousNinja thread starter macrumors regular

    AmbiguousNinja

    Joined:
    Jun 15, 2011
    #7
    Yeah it does, but it doesn't highlight
     
  8. tjb1 macrumors 68000

    Joined:
    Aug 26, 2010
    Location:
    Pennsylvania, USA
    #8
    Try double clicking on it? Sorry for the simple questions...
     
  9. AmbiguousNinja thread starter macrumors regular

    AmbiguousNinja

    Joined:
    Jun 15, 2011
    #9
    Haha it's okay, anything to solve this problem that's been annoying me for the past month!
    And yeah, I've double clicked it and clicked the little arrows.
     
  10. tjb1 macrumors 68000

    Joined:
    Aug 26, 2010
    Location:
    Pennsylvania, USA
    #10
    This is what my Preferences screens look like if this is any help to you.
     

    Attached Files:

  11. tjb1 macrumors 68000

    Joined:
    Aug 26, 2010
    Location:
    Pennsylvania, USA
    #11
    Also found some other information...


    Check to make sure your Region is set to your country rather than "custom".
    Apple Menu > Language&Text > Formats > Region > Your Country (Like United States)

    __Test iCal

    Make an iCal backup, File > Export > Archive.

    Remove the following to the trash and restart your computer:
    Home > Library > Caches > com.apple.ical or ical
    Home > Library > Calendars > Calendar Cache, Cache, Cache 1, 2, 3, etc. (Do not remove Sync Cache or Theme Cache)
    Home > Library > Preferences > com.apple.ical (There may be more than one of these. Remove them all.)
    __NOTE: Removing these files will remove any shared (CalDAV) calendars you may have access to. You will have to re-add those calendars to iCal > Preferences > Accounts.

    ---------------------------------------------------------------------

    All of my trouble went away after I opened Font Book, selected ALL of my fonts, selected "Resolve Duplicates" under the Edit menu. Voila.
     
  12. AmbiguousNinja thread starter macrumors regular

    AmbiguousNinja

    Joined:
    Jun 15, 2011
    #12
    Ahhhgh! I found my problem but it just created a bigger problem...
    The first photo is what shows when I click the top one and the second shows what pops up when I click the bottom one...NO AM!!!
     

    Attached Files:

  13. AmbiguousNinja thread starter macrumors regular

    AmbiguousNinja

    Joined:
    Jun 15, 2011
    #13
    Aha! I changed my format to Canada and it worked! Thanks!
     
  14. tjb1 macrumors 68000

    Joined:
    Aug 26, 2010
    Location:
    Pennsylvania, USA
    #14
    Yep, no problem...glad it worked for you!
     

Share This Page