Ambient Sensor Backwards

Discussion in 'MacBook Air' started by BWhaler, Feb 24, 2008.

  1. BWhaler macrumors 68030


    Jan 8, 2003
    I just noticed the ambient sensor on my MBA seems to work backwards.

    When it detects light, the keys light up.

    But in pitch black, the key lights turn off.

    Anyone else have this issue?
  2. Kinetic macrumors member

    Jun 29, 2007
    Yeah, this is pretty common if you check Apple's support site (and I think around here). Mine does the same thing. It's pretty annoying considered I paid so much but I've learned to live with it. It'll get fixed eventually. In the meantime, I just manually adjust it to make it come on. (That's fun to try and do in a completely dark room :) )
  3. Garemz macrumors regular

    Feb 7, 2008
    Edmonton Alberta Canada
    MAde IN China

    Yup Same problem here. Must be something to do with China being backwards, After all it's made in China:):D
  4. cedar macrumors regular

    Feb 2, 2008
    It's daylight in China when's it is dark in the states. Just jetlag.
  5. Cybergypsy macrumors 68040


    May 16, 2006
    Central Florida!
  6. nsbio macrumors 6502a


    Aug 8, 2006
    LORTNOC YTILAUQ (That's how they test the machines lately - BACKWARDS).
  7. dibara2003 macrumors 6502

    Aug 18, 2007
    i think it's a problem in the script they used. it's similar to the screen dimming one.
  8. wordy macrumors regular


    Feb 26, 2008
    I have the same "problem" with the keyboard backlight, but just wanted to clarify, the screen is supposed to dim in low light conditions - opposite of the keyboard backlight.

    It's shocking how many ppl on the apple forums don't seem to realize F5/F6 will solve the problem until apple posts a fix (which they claim to be working on).
  9. mactoday macrumors member

    Dec 13, 2006
    Moscow, Russia
    You know what? It's 2009 and Apple didn't fix this issue on their notebooks line! I have MacBookPro5,1 unibody 2.53Ghz revision A, and it's still have this backwards ambient light sensor issue and they have no solution. I have try to run Snow Leo GM and now back to 10.5.8 because they didn't solve the problem and looks like it's not a software problem.
  10. caonimadebi macrumors regular

    May 7, 2009
    If everyone has the same "problem", maybe it is because the keyboard was DESIGNED this way?
    The macbook is designed for the optimal user comfort, and I believe the ambient light sensor was coded to adapt to the ambient condition. The keyboard backlight, like the screen brightness, dims in a very-low-light environment, because it is the most comfortable to the eyes. In only moderately low-light condition, keyboard/screen brightness is turned up because the illumination will not be hard on the eyes (user's perception).
    Very-Low light: Keyboard and Screen are dimmed
    Moderately low light: keyboard is illuminated but turned up
    Ample light: Keyboard illumination is turned off
    However I'd be suspicious if your keyboard backlight turns completely off in pitch blackness.

    BTW your iphone has the exact same behavior. You'll understand why if you try typing a text message in a movie theater with the auto-brightness disabled.
  11. faxao macrumors regular

    Feb 20, 2008
    Milano, Italy
    Maybe I am one of the few lucky ones....

    but on my MBA Rev.B if I cover with my hand the top screen light sensor the screen will dim and the keyboard will light up.....this is how it is supposed to be working isn't it ? :) :apple:
  12. ayeying macrumors 601


    Dec 5, 2007
    Yay Area, CA
    Mine isn't backwards?

    When it gets dark, the screen darkens and the keyboard lights up to a 1/4 level. When ambient light increases, the keyboard light also increases along with the screen until a certain amount where the keyboard light shuts off and screen goes to 3/4 - full brightness.
  13. heywoodja macrumors member


    Feb 14, 2005
    Milpitas, Ca USA
    I hate it when people do this:

    BTW your iphone has the exact same behavior. You'll understand why if you try typing a text message in a movie theater with the auto-brightness disabled.[/QUOTE]

    So you are the type of person who text messages while in a movie theater? I hate it when people near me take out their phones and start texting. The screens are so bright, you might as well ring in a flashlight to annoy the s**t out of me. I am really just making a point and I am not bashing you. But to all of you other f**ks out there who texts while in a dark movie theater, I would rather you talk quietly into your phone then to light up your my section of the theater...
  14. wetrix macrumors 6502


    Dec 1, 2006
    Auckland, New Zealand
    I was just going to say that you don't want to admit to this here.
  15. wkw macrumors 6502


    Mar 23, 2004
    Eugene, OR
    cover the light sensor and turn the kb brightness all the way up. that will fix it. don't mess with it after that

Share This Page