AMD 5770 issue with 2008 Mac Pro

Discussion in 'Mac Pro' started by SDAVE, Feb 29, 2012.

  1. SDAVE macrumors 68040

    SDAVE

    Joined:
    Jun 16, 2007
    Location:
    Nowhere
    #1
    My 8800GT died so I ran to the Apple store and got an 5770. Well, it works fine under OSX and Windows 7, but sometimes under OSX before the boot, I get these random flashes and I have to hard boot to go back to OSX without an issue. Please see attached file for reference. It's currently connected to a 30" Apple Cinema Display via Dual Link DVI. This happens randomly.

    Cheers
     

    Attached Files:

  2. xgman macrumors 601

    xgman

    Joined:
    Aug 6, 2007
    #2
    Can you try a different cable to rule that out?

    Also, remove the card and re-seat it. If all else fails try another one from the same Apple store.
     
  3. SDAVE thread starter macrumors 68040

    SDAVE

    Joined:
    Jun 16, 2007
    Location:
    Nowhere
    #3
    What do you mean a new cable? It's the cable that is connected to the ADC and not my own.

    I guess I could try to reseat the card.
     
  4. SDAVE thread starter macrumors 68040

    SDAVE

    Joined:
    Jun 16, 2007
    Location:
    Nowhere
    #4
    I popped out the card and cleaned the PCIe lane with a dust remover...reseated it.

    I got a black screen upon the first boot and a hard restart fixed the issue.

    Do you guys think it's because this card is newer (PCIe-2x) and it's not "supported" by Apple? I know it works fine when it's actually in booted under OS X and Windows (Which I rarely use).

    Should I just get a replacement since it's under 30 days ?

    Really need to have my computer working, can't just hand the card in to Apple and wait for a new one.
     
  5. tony3d macrumors 6502

    Joined:
    Apr 6, 2006
    #5
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    I have the same card in the same machine with absolutely no issues. I would try another.
     
  6. SDAVE thread starter macrumors 68040

    SDAVE

    Joined:
    Jun 16, 2007
    Location:
    Nowhere
    #6
    Thanks! That's reassuring. I will get a replacement.

    P.S. Do you get that sudden black screen at the apple boot logo before the login screen appears? I was reading around the forum and it seems that others have a similar "issue". Using Lion.
     
  7. tony3d macrumors 6502

    Joined:
    Apr 6, 2006
    #7
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    No. Boots straight to white then logo.
     
  8. MacsRgr8 macrumors 604

    MacsRgr8

    Joined:
    Sep 8, 2002
    Location:
    The Netherlands
    #8
    FWIW, I got the Radeon 5870 inside my 2008 Mac Pro.
    "Officially" not supported, but working perfectly. No issues. No black screen boot.
     
  9. SDAVE thread starter macrumors 68040

    SDAVE

    Joined:
    Jun 16, 2007
    Location:
    Nowhere
    #9
    Thanks, guys.

    So I haven't gotten the issues anymore after dusting out the PCIe port and reseating the card.

    Should get a replacement just in case? I mean the card is new and I think the replacement would be a waste of time since none of my local apple stores carry it in stock right now and I have to make 2 trips to the store just to get it.

    Does Apple have 1 year warranty on these cards? How can I check?
     
  10. Ccrew macrumors 68020

    Joined:
    Feb 28, 2011
    #10
    Personally I'd see if it does it again before just clamoring for a new card. IIRC though the warranty is 90 days?
     
  11. Einz macrumors regular

    Einz

    Joined:
    Feb 14, 2008
    Location:
    Miami
    #11
    My first 5770 had intermittent problem. The 5770 is not officially supported. Don't mention your 2008 MP when asking for replacement. Otherwise, they will only give you a refund. I had to get the second card from Amazon.
     
  12. The-Pro macrumors 65816

    Joined:
    Dec 2, 2010
    Location:
    Germany
    #12
    Well if he gets a refund he can just buy a new one. They cant forbid him to buy one again.
     
  13. Macsonic macrumors 65816

    Macsonic

    Joined:
    Sep 6, 2009
    Location:
    Earth
    #13
    The Radeon 5770HD works fine in the 2008 MP. No black screen problems.
     

Share This Page