American flag randomly appearing in menu bar

Discussion in 'macOS' started by m i k e, Nov 25, 2007.

  1. m i k e macrumors member

    Joined:
    Aug 10, 2007
    #1
    I noticed today that the American flag (international symbol) randomly appeared in my menu bar. I was able to disable by going into the "International" settings but I don't like the idea that things are going on in Leopard without me doing anything. I feel like this happens periodically. The only thing I can think of is that maybe I hit a shortcut but I don't even think there is a shortcut to make the flag appear. Has anyone experienced the same thing or know why that may have happened? Thanks. I know it's not a huge deal but it's slightly annoying.
     
  2. SaSaSushi macrumors 68040

    SaSaSushi

    Joined:
    Aug 8, 2007
    Location:
    Takamatsu, Japan
    #2
    In the International Settings if you remove the check from the box that says "Show the input menu in menubar" that should take care of it. I don't know of a keyboard shortcut to enable the input in the menubar but cmd-1 and cmd-2 are the default shortcuts to rotate through the input systems you have configured on your system. If US English is the only input system you plan on using I would double check in International Settings that everything else is unchecked.
     
  3. Lone Deranger macrumors 65816

    Lone Deranger

    Joined:
    Apr 23, 2006
    Location:
    London
    #3
    You might accidentally be hitting command+spacebar which would switch through the various different keyboard layouts that you have ticked on in the 'Input Menu' under 'International' in System Preferences. You can turn this shortcut off by unticking both options of 'Input Menu' under the 'Keyboard Shortcuts' tab which can be found under 'Keyboard & Mouse'.
     
  4. Fiveos22 macrumors 65816

    Fiveos22

    Joined:
    Nov 20, 2003
    #4
    I thought command+spacebar was the hotkey for Spotlight, or has that changed in Leopard?
     
  5. SaSaSushi macrumors 68040

    SaSaSushi

    Joined:
    Aug 8, 2007
    Location:
    Takamatsu, Japan
    #5
    Yes, as I said the default hotkey for sorting through input methods is command+2 (next input source) and command+3 (previous input source). Making sure that the checkbox for showing the menu item in the menubar is unchecked and that English is the only input method installed should take care of the American flag showing up in the menu bar.

    Yes, command+spacebar is the default shortcut for Spotlight.
     
  6. rdowns macrumors Penryn

    rdowns

    Joined:
    Jul 11, 2003
    #6
    The Patriot Act requires you to display the flag in your menu bar. ;)
     

Share This Page