AMS doesn't detect Trigger Finger?

Discussion in 'Digital Audio' started by storage, Mar 2, 2007.

  1. storage macrumors 6502

    Jun 4, 2005
    I just got my M-Audio Trigger Finger, only problem is that the Audio/MIDI Setup utility doesn't recognize the controller. Neither do any audio applications (tried Live and Garageband).

    I've tried rescanning, unplugging it, rebooting and even reinstalling Mac OS X, but it led nowhere. The controller powers up and everything, it's just OS X that doesn't want anything to do with it for some reason.

    The M-Audio Trigger Finger is class-compliant so there are no drivers. Enigma doesn't recognize it either.

    Any ideas on how I can make it work?

    Thanks in advance.
  2. sangamc macrumors newbie

    Mar 22, 2006
    im having the exact same problem as you are. the trigger finger is not detected in either AMS or in reason or garage band. when i took it to my office and plugged it into a few different workstations (all pcs) it came up right away.

    if anyone has any ideas on this one, that would be great
  3. the vj macrumors 6502a

    Nov 23, 2006
    I just made it work some how. I am using Digital Performer and nothing, the audio midi set up shows the Trigger Finger but nothing. I opened a VJ software that used to work with the TF and nothing, I did a "detect midi devices" and vuala! now all the softwares recognize the TF.
  4. digidrums macrumors newbie

    Jul 6, 2005
    I know this thread is old, but in case someone else runs into this...

    My Trigger Finger doesn't work connected directly to any USB port on my iMac (3.06 GHz Intel Core 2 Duo w/10.6.5), but I got it working by plugging it into into a USB hub.

Share This Page