an album persistantly appears 2 times in cover flow

Discussion in 'iPod' started by Sossity, Dec 9, 2013.

  1. Sossity macrumors 6502a

    Joined:
    May 12, 2010
    #1
    I have an ipod classic 7th gen ipod, using the latest version of itunes.

    I have this one album that keeps appearing 2 times in the cover flow view of my ipod, I checked it in the album view & artist view on my ipod, and it shows up normally in those places. The album shows up normally in itunes on my computer.

    I did notice that the artist's name in this album was spelled a little differently than in the other albums by this same artist. Would this have anything to do with this? I also made sure to arrange the album so feature artists are in the song titles, and that the whole album has the same artist and album artist in the get info fields.

    Could there be a problem with my ipod? or is it in itunes? I run itunes from an external hard drive.

    Also, I just did a clean install of mac os Lion on my mac mini 2011, dont know if this could be affecting this as well.
     
  2. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #2
    If the spelling differs, then that's probably the issue...You could manually change it, by right clicking it in iTunes and see if that helps after syncing again.
     
  3. jcb10 macrumors regular

    Joined:
    May 14, 2008
    #3

    Agreed. Also check that the "album artist" is the same in all the songs, as is the number of discs (a blank in one song and a 1 in another could confuse iTunes).
     
  4. NinjaKid macrumors member

    Joined:
    Feb 20, 2008
    #4
    How to fix this

    if you import music and there is a difference in artist or spelling difference you will see a album broken up into different albums on the playlist, to fix this goto the song list for that album and select all the songs that belong in it, then right click the selected list and select get info, the last tab, I think its called options, select that you will then see options, check Part of a complication and select Yes from the pull down list, this should fix it
     

    Attached Files:

  5. Sossity thread starter macrumors 6502a

    Joined:
    May 12, 2010
    #5
    Thanks everyone for the suggestions, I found a way to get it to stay as one album, I added sort by artists, & album artist and that seemed to fix it.
     
  6. cambookpro macrumors 603

    cambookpro

    Joined:
    Feb 3, 2010
    Location:
    United Kingdom
    #6
    Yeah, the 'Sorting' tab is almost always the problem. Once I had an artist spelt with an 'and' in the sort view for one song and an ampersand in another. Drove me crazy as I couldn't figure out why they weren't grouping together!
     

Share This Page