An elusive external hard drive

Discussion in 'Mac Basics and Help' started by Glockenklang, Dec 16, 2012.

  1. Glockenklang macrumors newbie

    Dec 16, 2012
    Hello all,

    My problem centers around a 2 TB external hard drive: a Rocketfish RF USB 3.0 3.5" SATA Hard Drive (RF-HD3035)

    I have a 17" MacBook Pro running OS X Lion 10.7.5.
    I have a 13" MacBook Air running OS X Lion 10.7.4.

    The Air can read the external hard drive. The Pro cannot. On the Pro, the hard drive appears in the finder, but when I click on the folders within, they present as empty.

    When I run Disk Utility, it tells me the drive needs to be repaired. When I click "repair disk", it says "Error: Can't Unmount Disk".

    Again, no problems to speak of on the Air running 10.7.4.

    This all MAY have begun when I updated the Pro to 10.7.5. (can't remember which happened first, the hard drive problem or the update.)

    I tried this but it didn't help.

    Do you think the update might have caused the problem?

    Thank you in advance for your help, folks!

    All the best,

  2. mankar4 macrumors 6502a


    Aug 23, 2007
    I had a similar problem and ended up having to reformat :(

Share This Page