An old problem on an old mac -- mac freezes on shutdown

Discussion in 'macOS' started by theman, Nov 30, 2011.

  1. theman, Nov 30, 2011
    Last edited: Nov 30, 2011

    theman macrumors 6502a

    Jul 26, 2007
    I have a 2007 MBP, and for maybe 3 years or more I've been having an issue on shutdown. I haven't really worried about it since restarting/shutting down is a very uncommon event for me, but I'm in a weird mood today and wondered if maybe someone knew what the deal was.

    Basically, when I shut down or restart, the screen will go black, and the white indicator light at the front of the MBP will stay on very dim. It will stay like this indefinitely, fans still spinning. I have to hold down the power button to get it to shut off, and push it again to get it to restart. The problem is fairly intermittent, it happens maybe 60-70% of the shutdowns. I haven't found any pattern for when it does or does not happen. Also, I had my logic board replaced over a year ago for an unrelated issue, and that didn't seem to change anything. Oh, and I'm running 10.5.8, I've had 10.5 since it came out (just after I bought the machine).

    After the MBP boots back up I get a message on the desktop that says something like, "The computer restarted after Mac OS X quit unexpectedly, send error report?"

    Anyone seen something like this before?

    Edit: Here's what I get from crash reporter, if this means anything to anyone:

    Interval Since Last Panic Report:  968805 sec
    Panics Since Last Report:          3
    Anonymous UUID:                    79637659-84FC-418C-9B44-6DCA91E00299
    Wed Nov 30 10:56:10 2011
    panic(cpu 1 caller 0x001AB0FE): Kernel trap at 0x51ad2214, type 14=page fault, registers:
    CR0: 0x8001003b, CR2: 0x000005a4, CR3: 0x014cc000, CR4: 0x00000660
    EAX: 0x0066b3e2, EBX: 0x00000054, ECX: 0x005156a4, EDX: 0x052dc554
    CR2: 0x000005a4, EBP: 0x2eb77c88, ESI: 0x04571000, EDI: 0x51ad43e8
    EFL: 0x00010202, EIP: 0x51ad2214, CS:  0x00000008, DS:  0x00000010
    Error code: 0x00000000
    Backtrace (CPU 1), Frame : Return Address (4 potential args on stack)
    0x2eb77a98 : 0x12b4c6 (0x45f91c 0x2eb77acc 0x13355c 0x0) 
    0x2eb77ae8 : 0x1ab0fe (0x469a98 0x51ad2214 0xe 0x469248) 
    0x2eb77bc8 : 0x1a1713 (0x2eb77be0 0x206 0x2eb77c88 0x51ad2214) 
    0x2eb77bd8 : 0x51ad2214 (0xe 0x48 0x2eb70010 0x10) 
    0x2eb77c88 : 0x51ad076b (0x51ad4428 0x4571000 0x67abd4 0x3f0942) 
    0x2eb77cb8 : 0x51ad07ee (0x4571000 0x686fdc 0x2eb77ce8 0x3f14a4) 
    0x2eb77cd8 : 0x414277 (0x51f7880 0x0 0x4571000 0x3f1571) 
    0x2eb77d08 : 0x414f90 (0x4571000 0x4759c40 0x0 0x4571000) 
    0x2eb77d48 : 0x418b60 (0x4571000 0x4264c40 0x0 0xffffffff) 
    0x2eb77d98 : 0x418d13 (0x4593f00 0x7 0x1 0x425b2b) 
    0x2eb77db8 : 0x5aacb2 (0x4593f00 0x3 0x1 0x4593f00) 
    0x2eb77dd8 : 0xb38643 (0x4593f00 0x3 0x44ee004 0x44ee000) 
    0x2eb77e18 : 0xb387b7 (0x44f1e00 0x5c60e4 0x1 0x0) 
    0x2eb77e58 : 0xb33fcd (0x44f1e00 0x4f43ba0 0x4f43ba0 0x4f43bb8) 
    0x2eb77e98 : 0xb37120 (0x44f2c00 0xb34aa6 0x1 0x0) 
    0x2eb77ed8 : 0x41c606 (0x44f2c00 0x1 0x44f2c00 0x44f2c00) 
    	Backtrace continues...
          Kernel loadable modules in backtrace (with dependencies):
    BSD process name corresponding to current thread: kernel_task
    Mac OS version:
    Kernel version:
    Darwin Kernel Version 9.8.0: Wed Jul 15 16:55:01 PDT 2009; root:xnu-1228.15.4~1/RELEASE_I386
    System model name: MacBookPro3,1 (Mac-F4238BC8)
    System uptime in nanoseconds: 1051358615098
    unloaded kexts:	2.4.0 - last unloaded 152459649193
    loaded kexts:
    com.baltaks.driver.DoubleCommand	1.6.5
    com.vmware.kext.vmnet	1.1.3
    com.vmware.kext.vmioplug	1.1.3
    com.vmware.kext.vmci	1.1.3
    com.vmware.kext.vmx86	1.1.3	1.5.5 - last loaded 262784283215	2.1	1.9d0	2.0.2	2.1.9f10	2.7.5	1.7.1a2	6.0.3	5.4.8	5.4.8	320.16.2	1.7.1a2	2.1.1d2	113	1.0.6	1.4.5d1	3.4.0a17	1.3.1	1.6.0	1.7.7	2.1.9f10	1.7.4f1	1.7.4f1	1.7.4f1	3.5.2	2.1.1	2.1.1	2.7.91	1.5.3	1.2.2	1.7.0	2.0.1	3.4.9	3.5.2	3.9.7	3.1.13b2	3.4.6	3.5.2	1.2.0	158.10.5	1.2.3	1.4	1.2.5	1.2.5	1.4	1.2.5	1.4	107.12	1.8.77	3	76.2.0	199	30.4	9.4	1.7.1a2	5.4.8	216.1	1.7.1a2	1.6.9fc5	1.1	3.4.0a17	2.3.1d1	1.7.3	1.7.3	2.1.9f10	2.1.9f10	3.4.6	3.2.0	2.1.1	1.5	1.5	1.5	2.1.1	1.5.0	2.0.1	3.4.9	1.6.1	3.5.2	1.2.0	1.1	1.5.6	1.5.5	1.2.5	1.2.0	2.6
  2. ArchiMark macrumors 6502

    Feb 2, 2003
    Silicon Valley
  3. theman thread starter macrumors 6502a

    Jul 26, 2007
    I've tried resetting SMC before, didn't seem to help. Is there any corruption check I can do with Onyx? I have that app.
  4. ArchiMark macrumors 6502

    Feb 2, 2003
    Silicon Valley
    Onyx can check if permissions are out of whack, so, you do that.....but don't know if that could cause your issue....but couldn't hurt....

    Also, run Apple's Disk Utility and check disks....

    Best is to get DiskWarrior and/or TechTool Pro, preferably both....
  5. theman, Nov 30, 2011
    Last edited: Nov 30, 2011

    theman thread starter macrumors 6502a

    Jul 26, 2007
    Ha, nevermind, I do have diskWarrior! Totally forgot about it, I used it a couple years ago to save files from a failing external... anyway, I ran a scan and got 2 results:

    File: ""
    Location: ~/Library/Preferences
    --Property List data is damaged and cannot be repaired

    File: ".intelligence"
    Location: /usr/share
    --Resource header is damaged and cannot be repaired

    Seems that .intelligence is a leftover from some old app I had installed, and iphotomosaic I'm not sure of, but I can't imagine it would be causing this problem.
  6. ArchiMark macrumors 6502

    Feb 2, 2003
    Silicon Valley
    Delete both files and restart Mac and then see how things go...sometimes damaged files can make your Mac do wacky things I've found in the past...

    Also, highly recommend that update your DiskWarrior version...go to Alsoft's website and get updater and make new disk....
  7. theman thread starter macrumors 6502a

    Jul 26, 2007
    No luck, deleted the files and same issue when I restarted.

Share This Page