Android e-mail app that supports iCloud aliases

Discussion in 'Alternatives to iOS and iOS Devices' started by timeconsumer, Nov 17, 2016.

  1. timeconsumer macrumors 65816

    timeconsumer

    Joined:
    Aug 1, 2008
    Location:
    PNW
    #1
    I've recently switched to a Pixel but the one thing that I've noticed is that I can't seem to find an e-mail app on Android that supports sending from iCloud aliases.

    I have a main account name that I use for logging in only, then I have 3 other aliases that I use for different things such as personal, professional and all others. This allows me to keep my login name separately from my e-mail addresses and also ties my accounts together without having to register multiple e-mail addresses and thus maintaining separate passwords/two-factor authentication for all.

    I can receive e-mail sent to those aliases, I just can't reply or send new e-mail from any of those aliases.

    Does anybody know of an app that would allow me to use my iCloud aliases in this way?
    --- Post Merged, Nov 17, 2016 ---
    Update: After testing out some e-mail apps, I've found that Outlook can handle this.

    In Outlook go to: Settings, then select your iCloud account, then go to Advanced Settings, then Add Alias.

    To setup iCloud aliases can be done by following this support article: https://support.apple.com/kb/ph2622?locale=en_US

    Then you can send or reply to e-mail. One thing I will note is that it doesn't seem to default to the alias that the sender used. This is somewhat annoying as I am used to this in the iOS mail app, but it's better than what I was doing before!
     
  2. mi7chy macrumors 68040

    mi7chy

    Joined:
    Oct 24, 2014
    #2
  3. timeconsumer thread starter macrumors 65816

    timeconsumer

    Joined:
    Aug 1, 2008
    Location:
    PNW
  4. theinstructor macrumors regular

    theinstructor

    Joined:
    Jul 13, 2007
    #4
    Outlook does but you have to go to advanced settings in the app to change that and you add the alias and set it as your default. Not great but it works.
     

Share This Page