Android PHONE not detecting

Discussion in 'MacBook Pro' started by Metro50, Oct 22, 2014.

  1. Metro50 macrumors newbie

    Joined:
    Oct 22, 2014
    #1
    What's up guys.
    I've been on a long hiatus on a Mac and am
    coming across a small glitch with my cell phone not
    detecting on my MBP Retina.

    It seems to be not detecting my Galaxy S4.
    Other USB devices are detecting just fine, but
    don't have an apple phone to see if it's an android issue.
    The S4 detects on a PC right away so assume it's the
    OS (Maverick 10.9) newly installed btw.

    Any opinions are up for grabs and greatly appreciated.
    thx!
     
  2. hallux macrumors 68020

    hallux

    Joined:
    Apr 25, 2012
    #2
  3. Metro50 thread starter macrumors newbie

    Joined:
    Oct 22, 2014
    #3
    ok good to know.
    will give it a go thx!

    ----------

    Just installed it but no joy.
    I am running Kitkat 4.4 btw.
    I heard this newest version may be the culprit.
    not sure.
     
  4. brdeveloper macrumors 68020

    brdeveloper

    Joined:
    Apr 21, 2010
    Location:
    Brasil
    #4
    Android file transfer actually isn't a good option. It doesn't get updates for years, you can't preview pictures, etc. It's better installing a Samba server on your phone, then mount the share on your Mac (Finder->Connect To Server) so you can transfer files via Wi-Fi.
     
  5. hallux macrumors 68020

    hallux

    Joined:
    Apr 25, 2012
    #5
    I use AFT to connect my Moto X running 4.4.4 on the RARE occasion I need to do so. It's not related to the Android version.
     
  6. crsh1976, Oct 23, 2014
    Last edited: Oct 23, 2014

    crsh1976 macrumors 6502a

    Joined:
    Jun 13, 2011
    #6
    Make sure your option to mount your phone as a USB storage device is enabled.

    Parameters > Storage > Option menu (top right icon) > USB connection > the MTP checkbox needs to be checked

    I use AFT on my MBP with my Nexus 5 (4.4.4) and it works like a charm; as mentioned above, you need to transfer files to your Mac before you can preview them, that's one limitation, but otherwise it's straight-forward enough for a quick & dirty solution.
     
  7. Metro50 thread starter macrumors newbie

    Joined:
    Oct 22, 2014
    #7
    many thx brdeveloper for the tip, but rather
    not transfer files via wifi. USB works for me.
    I tried AFT again on both cell and mac,
    but am getting a cannot connect to a device error message.
    Tried the usual unplug re-plug and restart phone
    w/o success.

    Any other software or app I can try via usb?
     
  8. s0nicpr0s macrumors regular

    s0nicpr0s

    Joined:
    Sep 1, 2010
    Location:
    Illinois
    #8
    Did anything show up on your phone's screen? When I hooked my Nexus 4 in the other night, I believe I needed to pull down the notification shade to tell it to use the USB. Then I was able to use AFT just fine to copy over all of my pictures.
     
  9. GoingDark macrumors 6502

    Joined:
    Nov 2, 2013
    #9
    I could never get Android File Transfer to work on my HTC One. I ended up going with a free android app called Droid NAS that lets you connect over wifi, but I know you said a few posts above that you prefer to connect via USB.

    Other than Android File Transfer, or running a virtual machine with Windows installed on it, I don't have any other USB options that I can think of. OS X just doesn't play nice with Android unfortunately.
     
  10. hallux macrumors 68020

    hallux

    Joined:
    Apr 25, 2012
    #10
    I just use bluetooth. When I transfer a file to my Mac from my phone it's usually just a picture so it's a quick transfer.
     
  11. alex0002 macrumors 6502

    Joined:
    Jun 19, 2013
    Location:
    New Zealand
    #11
    I'm using the Airdroid app and upload/download/manage the phone from the browser.
    http://www.airdroid.com/

    No cables required. Most of the time you can just use it in 'Lite' mode with wifi and don't need to sign into the airdroid site.
     
  12. Metro50 thread starter macrumors newbie

    Joined:
    Oct 22, 2014
    #12
    thx all for the replies.
    No doubt the suggested apps will work for most,
    but really need to use usb to cut back on my data.
    Bluetooth hogs up my data plan.
     
  13. cjmillsnun macrumors 68020

    Joined:
    Aug 28, 2009
    #13
    How does Bluetooth use your data plan??? Bluetooth is not a connection to the mobile network.
     
  14. Concorde105 macrumors newbie

    Joined:
    Sep 1, 2009
    #14
    Yeah this has been happening for me lately, really annoying.

    The only workaround I've found so far is to shut down the computer, plug in your phone with USB, and then start the computer up. This lets android file transfer recognize the phone.

    I just use airdroid on wifi whenever possible, so android file transfer is just used on airplanes now.
     
  15. Metro50 thread starter macrumors newbie

    Joined:
    Oct 22, 2014
    #15
    CJ check your current data plan then use bluetooth and transfer a file then check your data plan again. You'll see the increase. Surprised me too.

    As far as the USB upon startup is concerned will give that a go
    too concorde thx.

    Worst case scenario I guess I can transfer all my files on a usb
    on my PC first then the MAC until I find a permanent or better
    workaround fix.

    cheers.
     
  16. hallux macrumors 68020

    hallux

    Joined:
    Apr 25, 2012
    #16
    Is it possible you were pulling that file from a web location and pushing it to the computer using Bluetooth? Bluetooth is a local peer to peer protocol, there should be NO hit to an external connection when you transfer from one device to another using the bluetooth protocol.

    I just tried transferring a picture stored locally on my phone to my Mac using bluetooth. Before the transfer I had 454 MB used, after I had 454 MB used (based on the phone's report of data usage), the file was over 2 MB.
     
  17. Metro50 thread starter macrumors newbie

    Joined:
    Oct 22, 2014
    #17
    hmm....it's possible.
    Can't recall at the time.
    Will see if that's the case later on tonight.
    If that is the case that would work for me temporarily.
     
  18. Metro50 thread starter macrumors newbie

    Joined:
    Oct 22, 2014
    #18
    recent update.

    I found a temporary workaround for those in a similar pickle.
    I downloaded Kies for Samsung and just transfer my photos
    and vids there until I find a better solution.
     

Share This Page