Androidlock XT not so secure?

Discussion in 'Jailbreaks and iOS Hacks' started by zmulleni, Aug 8, 2010.

  1. zmulleni macrumors regular

    zmulleni

    Joined:
    Jun 28, 2010
    #1
    Wondering if this is just an isolated instance or not. With Androidlock XT installed with a custom pattern set I thought I would try to slide like normal from left to right on the bottom part of the screen, and to my surprise it worked. My custom pattern involves sliding through the upper two rows so I'm wondering what's going on. Anyone with similar issues?

    Visual: slide the bottom row from left to right
    [​IMG]
     
  2. iMrNiceGuy0023 macrumors 68000

    Joined:
    Jun 5, 2009
    #2
    did you save the pattern??

    has it been updated for 4.o yet?
     
  3. xcel360 macrumors regular

    Joined:
    Jul 25, 2008
    Location:
    WPB, Fl
    #3
     
  4. wingnut8 macrumors 65816

    wingnut8

    Joined:
    Jun 8, 2007
    #4
    Couldn't you just hold down the home button for voice command, try to make a call, during the call hit the home button and change or disable the pattern?
     
  5. iMrNiceGuy0023 macrumors 68000

    Joined:
    Jun 5, 2009
    #5
    what did you use for the weather on the lock screen?
     
  6. zmulleni thread starter macrumors regular

    zmulleni

    Joined:
    Jun 28, 2010
    #6
    The pattern was saved and verified, and it has been updated to iOS4 although I'm currently on 4.0.1 at the moment. Also I forgot to mention that if I put in my saved pattern it will unlock as well... So essentially I have two ways to unlock the device.

    I'm using lockinfo with lockweather plugin for the upper portion of the screen.
     
  7. PhantomZone macrumors 6502

    Joined:
    Jul 2, 2009
    #7
    I can't replicate your issue....AL XT does have another issue at present where if you have bitesms installed and you click to view a text message, it automatically logs you in and bypasses the unlock!

    I've reported this to the dev so we'll see what happens!
     
  8. zmulleni thread starter macrumors regular

    zmulleni

    Joined:
    Jun 28, 2010
    #8
    No sir, that's actually what I enjoy about the app... It reverts right back to that lock screen. I've even tried various voice commands as well as the iPod commands. Essentially it does have a fail-safe where you can call the phone hang up and then access the settings feature.
     
  9. artou007 macrumors newbie

    Joined:
    Sep 18, 2010
    #9
    Any combo works!! :O

    Same issue here. My specified passcode, along with pretty much ANY other (greater than three length) pattern will unlock the device. Running os 4.

    OS4 support is fine, so is this an issue with the firmware or the version of Androidlock?

    Actually quite scary, as being able to put in any combination and unlock the device makes the software as useless as disabling the lock screen altogether.
     

Share This Page