Annoyance: Finder wants to make changes

Discussion in 'Mac OS X Lion (10.7)' started by dumb, Sep 22, 2011.

  1. dumb macrumors member

    Joined:
    Nov 1, 2009
    #1
    I receive this message, every time I try to delete, or rename files., Finder wants to make changes... and asks me to enter password for authentication.
    I fixed permissions from disk utility. Also, I clicked on my userName>Get Info> Permissions and Sharing> Read & Write> Applied to Enclosed Items.

    Still asks me to authenticate. I would appreciate some help.

    P.S I did Google and those were the two recommended steps.
     
  2. dumb, Sep 25, 2011
    Last edited by a moderator: Apr 18, 2013

    dumb thread starter macrumors member

    Joined:
    Nov 1, 2009
    #2
    I tried to bulk rename my photos with Name Mangeler, I have to authenticate with password for each file name change. This is driving me nuts. Help!.
     
  3. Nuckinfuts macrumors 6502

    Joined:
    Jun 15, 2011
    Location:
    Syracuse, NY
    #3
    Had this problem too and just found the solution.

    Open Terminal and type:
    Code:
    sudo chown $USER ~/.Trash
    My .Trash folder got assigned to root
     
  4. dumb thread starter macrumors member

    Joined:
    Nov 1, 2009
    #4
    Sorry, that did not work. Any other ideas, to fix permissions.

    I don't know much Unix but i tried sudo chown -R 777 Users/username out of desperation did not work either.
     
  5. Farthen macrumors member

    Joined:
    Feb 3, 2009
    Location:
    Germany
    #5
    Can you try:
    sudo chown -R $USER:staff ~
    sudo chmod -R 755 ~
    (assuming an administrator user)
     
  6. dumb thread starter macrumors member

    Joined:
    Nov 1, 2009
    #6
    Thanks guys for the help, I'd followed instruction on this article, however missed the second last paragraph.

    This command sudo chmod -RN ~ and may be a combination, of whatever I tried (seems) to have fixed he issue.

    Edit: Link to article http://www.macworld.com/article/139833/2009/04/finder_permissions.html
     
  7. rawvie macrumors newbie

    Joined:
    Apr 18, 2013
    #7
    You are the best

    thank you so much finely someone who know how to fix that problem
    :D:apple:
     

Share This Page