annoyance: iTunes jumps to song playing when browsing library

Discussion in 'Mac Apps and Mac App Store' started by IdiddidI, Jan 25, 2008.

  1. IdiddidI macrumors member

    Joined:
    Jan 22, 2008
    #1
    One of my biggest gripes with iTunes is that if I'm browsing my music library while listening to a song, and a new song begins playing, the music library jumps to that song, and I have to scroll back to where I was in the library.

    For example, if I'm pulling songs out of my library to add to a playlist, I lose my spot in the library every time a new song begins playing.

    Does anyone know a way to prevent this (besides listening only to songs in a playlist while working with the library)?
     
  2. GSMiller macrumors 68000

    GSMiller

    Joined:
    Dec 2, 2006
    Location:
    Kentucky
    #2
    I don't believe there is a way to prevent iTunes from doing that, at least I couldn't find anything under Preferences.
     
  3. phairphan macrumors 6502a

    phairphan

    Joined:
    Sep 21, 2005
    Location:
    Reject Beach
    #3
    I find this incredibly annoying too as I'm prone to surfing around my library looking for something to play while I'm listening to something else.

    I have been unable to discover a means of disabling this behaviour, but I have developed a kludgey work-around. Create a smart playlist that replicates your entire library (like time > 0, year > 0, or whatever works for your library and tagging scheme). Then while playing a song in your main library, you can surf in the smart playlist and if the track changes, you don't lose your place. Then when you pick something to play in the smart playlist, browse in the main library, and rotate back-and-forth. Usability sounds worse than it actually is, particularly if you name your smart playlist something that puts it at the top of your list of playlists, so you don't have to go scrolling down all the time (if you have a lot of playlists). Hope you find this of use.
     
  4. Cinematographer macrumors 6502a

    Cinematographer

    Joined:
    Sep 12, 2005
    Location:
    far away
    #4
    That's strange. My iTunes isn't doing that. Just tested a few constellations. It's never doing something like that. :confused:
     
  5. IdiddidI thread starter macrumors member

    Joined:
    Jan 22, 2008
    #5
    This is a great tip--I'm going to set up this playlist tonight... though I do wish Apple would address this issue. If you want to see the current song playing, you can always use Cmd-L. No need to bring the song into view just because it starts playing.
     
  6. Rapmastac1 macrumors 65816

    Rapmastac1

    Joined:
    Aug 5, 2006
    Location:
    In the Depths of the SLC!
    #6
    I hate this too! It's when I'm encoding songs and stuff that it bugs me the most. What I do is after I have gotten a ton of songs, I encode them so they are all in the same bitrate and file format and I select a ton at once and a song will start to play making me jump to it and then deselecting all the files I have selected for deletion after the encoding is complete. The only work around I have for this is just checking and unchecking the files that I am encoding.

    I have looked around and there are no preferences for it. The best work around mentioned here is a really good idea as it remembers your place...
     

Share This Page