Annoyance: Right clicking in some apps maximizes the window

Discussion in 'OS X Mountain Lion (10.8)' started by VirtualRain, Aug 13, 2012.

  1. VirtualRain, Aug 13, 2012
    Last edited: Aug 13, 2012

    VirtualRain macrumors 603

    VirtualRain

    Joined:
    Aug 1, 2008
    Location:
    Vancouver, BC
    #1
    There seems to be a bug in several apps whereby right-clicking causes the app window to maximize (fill the screen).

    So far apps I've noticed that do this are:
    - Mail (right clicking an attachment)
    - Finder/iCal/Preview (right clicking in the search field)
    - PowerPoint 2011 (right clicking in the slide thumbnail pane)

    It's the strangest thing and most annoying. Is this unique to me? Has anyone figured out how to stop this?

    BTW this happens whether I use the touchpad built into my MBA or the Magic Mouse. :(
     
  2. nyolc8 macrumors regular

    Joined:
    Jul 20, 2012
    #2
    I tested right clicking in Mail on an attachment, and in Finder I rightclicked on the search field and nothing happened. Just the rightclick-menu popped up as it should.
     
  3. roestuff macrumors newbie

    Joined:
    Sep 20, 2012
    #3
    How do you turn off window maximization upon right mouse click?

    Hi, I am having this same annoying problem after installing mountain lion. At first I thought it was something Apple changed to make the user experience better for most people. But I hate it. Is there a way to turn off the way a window maximizes when you right click either the magic mouse or the track pad? Thank you.
     
  4. kenocrates macrumors newbie

    Joined:
    Jun 14, 2013
    #4
    Similar problem and solution

    This problem sounds similar to one reported at superuser and the solution there worked for me: exit the SecondBar application.
     
  5. danmcq macrumors newbie

    danmcq

    Joined:
    May 16, 2011
    #5
    Sure enough, closing SecondBar solved the issue for me. Thanks for the tip!
     
  6. vidapura macrumors newbie

    Joined:
    Apr 4, 2014
    #6
    Drat!!!

    Drat....It worked!
    Closing SecondBar fixed it...

    But I like secondbar.... now what am I gonna do?

    Vida

    ps: thanks for the help...
     

Share This Page