Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

caubeck

macrumors 6502
Original poster
Nov 2, 2007
417
4
As I need to compose texts using vocabulary Pages does not recognize, it underlines words or whole phrases in red. When that happens the options for copy, cut, bold etc. don’t pop up. Other than turning off the correction feature, is there a workaround? I’m trying to format a book using Pages instead of Word but little problems like this slow me down.

The pause between selecting text and being able to drag or adjust the selection is also infuriating. It’s just long enough to cause me to lose the selection and need to select again. Maybe it’s just me, of course, and my iPad Pro 2020 (iOS 14-15).
 

Slartibart

macrumors 68040
Aug 19, 2020
3,011
2,715
First: When you add a new keyboard to your iPad/iPhone, it automatically enables you to type and get predictive suggestions in these languages. Further, the autocorrect will not try to change the word.

Second: works brilliantly in Messages, but not in Pages AFAIK. The active keyboard defines the language used for autocorrection. You can toggle trough the keyboards and most likely all words written in another language will be underlined/flagged. There seems to be no multilingual support like on MacOS.

TL;DR: autocorrect on iPadOS works only on monolingual documents as long as you have the corresponding language as a (1./2./3./etc.) keyboard installed and it is selected.
 
  • Like
Reactions: caubeck

0128672

Cancelled
Apr 16, 2020
5,962
4,783
As I need to compose texts using vocabulary Pages does not recognize, it underlines words or whole phrases in red. When that happens the options for copy, cut, bold etc. don’t pop up. Other than turning off the correction feature, is there a workaround? I’m trying to format a book using Pages instead of Word but little problems like this slow me down.

The pause between selecting text and being able to drag or adjust the selection is also infuriating. It’s just long enough to cause me to lose the selection and need to select again. Maybe it’s just me, of course, and my iPad Pro 2020 (iOS 14-15).
I know exactly what you mean. Assuming you're in the US, I found the solution is to select Automatic - US as your keyboard language, and keep Checking Spelling enabled in iOS/iPadOS Pages. It should not flag normal words but will flag obvious errors and typos.

I'm using a hardware keyboard via my iPad Combo Touch on iPadOS 15.01. When I had the hardware keyboard language set to US (not the Automatic option), the Pages spell checker was flagging the most basic English language words like "time" and "other" and, as you said, whole correctly typed phrases, which is of course, incorrect behavior for the spell checker.
 
  • Like
Reactions: caubeck
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.