Annoyed with ._ files

Discussion in 'macOS' started by silvrbullet, Mar 23, 2010.

  1. silvrbullet macrumors regular

    Joined:
    Jun 19, 2009
    #1
    I have been having a lot of issues with my Ford Sync giving me "bad media" error messages. I have come to find out that this is caused by SL putting a "._filename.MP3" file for every MP3 I copy over to either my ipod or my USB drive. When using a USB drive, I can plug it into my windows machine at work and delete these files off, and it works great. But how can I stop this from happening? I would like to use my ipod in the car, but I cant delete the ._ files off. I also can't see these files in SL when I show hidden files...

    For those of you that dont know, Ford Snyc is developed my Microsoft and allows you to hook up a USB MP3 device to the factory radio.

    The USB drive is formatted FAT32.
     
  2. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #2
    Believe me it's not just a Ford Sync problem. The best thing to do is pick "show hidden files" in Finder and go around and delete them yourself. There is a setting in Preferences to avoid creating those files on network drives but Apple stupidly still forces them to be created on usb sticks. There is 3rd party software available to delete them as well. One thing you can do is open terminal, cd to the usb stick, probably in /Volumes/USB Stick Name then type \rm -rf ._*.mp3
    and then type cd by itself which takes you to your home directory and immediately eject the usb stick. The files will show up again the next time you connect your usb stick. There is a way to do the rm recursively as well. I think it's \rm -R -rf ._*.mp3
    be very careful when typing rm -rf anything. Take your time or you will find your music is gone quicker than you can hear the click of your last keystroke.

    The reason those files are there is to contain OS X specific meta information about your files. On removable media, it's meta information that is absolutely useless and Apple really should stop creating those files without asking...
     
  3. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #3
    I run a script for deleting them. From Terminal,
    Code:
    cd /Volumes/[I]WhateverYourDriveIsNamed[/I]
    find . -name '._*' -delete
     
  4. silvrbullet thread starter macrumors regular

    Joined:
    Jun 19, 2009
    #4
    Sweet! Thanks guys! Will terminal command also work for my ipod?


    BTW- I guess I should have mentioned I'm new to Mac's!
     
  5. hoosker macrumors member

    hoosker

    Joined:
    Jun 17, 2003
    #5
    Where is this setting?. Is it available in 10.4, 10.5, or just 10.6? I mount Windoz shares at work and would love to avoid this.

    thanks
     
  6. Hal Itosis macrumors 6502a

    Hal Itosis

    Joined:
    Feb 20, 2010
    #6
    Enter this in Terminal.app:

    defaults write com.apple.desktopservices DSDontWriteNetworkStores -bool YES
     
  7. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #7
    Yes, it will work with any drive connected to your Mac as long as it understands the file system used on it (including HFS+, FAT, NTFS with 3rd-party software).
     
  8. silvrbullet thread starter macrumors regular

    Joined:
    Jun 19, 2009
    #8
    Hopefully this isnt too noobish of a question, but what exactly do I need to type into terminal?

    I first typed in "cd/Volumes/CRUZER" hit enter, and it said "something about an invalid directory?
     
  9. Hal Itosis macrumors 6502a

    Hal Itosis

    Joined:
    Feb 20, 2010
    #9
    Need a space after cd:
    cd /Volumes/CRUZER

    [command argument]
     

Share This Page