Annoying behaviour on O2 network yesterday

Discussion in 'iPhone' started by Moi un Mouton, Jan 23, 2010.

  1. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #1
    I was over in Guildford yesterday and tried to use Maps, the phone showed a strong 3G signal but maps wouldn't load. Couldn't get web pages either.

    I figured the 3G network was down, so I turned off 3G and rebooted the phone, now it showed 4 bars of Edge, and Maps worked OK.

    A bit later I was further south still with an Edge signal, I turned 3G on again to see if it was working, and now the phone showed "No Service". Turned 3G off again, still no service. Switched Airplane mode on then off, and now it searched and got my Edge signal back.

    I repeated that test again later - as soon as I turned 3G on the phone would say "no service", and to get any signal back I had to turn 3G off AND switch though Airplane mode.

    Why does it do that? Shouldn't the phone behave better:
    1. In the first place, go to Edge/GPRS for data if the 3G service doesn't respond
    or
    2. Go to the Edge/GPRS automatically if I turn 3G off in Settings

    I had at least a bit of a clue what to try because of stuff on this forum, but I reckon the average phone user would just be stuck blaming O2.
     
  2. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #2
    The iPhone has always had trouble hopping back and forwards over 3g and edge.
     

Share This Page