Annoying Bluetooth icon in the menu bar

Discussion in 'OS X Mountain Lion (10.8)' started by H.Finch, Jul 12, 2013.

  1. H.Finch macrumors regular

    Joined:
    Jun 9, 2013
    #1
    Hi All,

    Just a little question... has anyone got an idea how I can turn off the Bluetooth icon in the top menu bar of OSX? I mean really turn off?

    Because when I turn if off by going to the Bluetooth settings 'Show menu bar icon' it just comes back when my mouse battery level dips below 10%... and it starts sort of flickering...which is REALLY annoying since my mouse will still last a full day or more when it's below 10%....

    So esentially I have a flickering icon...which I didn't ask for, and it seriously bugs me while working... It just shouldn't be there... if my mouse is empty I'll know... I don't need an icon tellin me full-time 'it's going to disconect' sometime in the next few days...

    Anyone got a solution to this?
     
  2. madmacfan macrumors 6502

    Joined:
    Feb 19, 2012
    Location:
    London, United Kingdom
    #2
    Hit the CMD key and at the same time click on the bluetooth icon and drag it out of the menubar.
     
  3. H.Finch thread starter macrumors regular

    Joined:
    Jun 9, 2013
    #3
    Isn't that the same as turning it off in settings? I had a great tweak to turn off and remove notification centre from my menu bar, but it was a little more compicated... some terminal script was needed... maybe there's something for the bluetooth icon as well...
     
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    Yes, this has the same result as unchecking the box in my screenshot. BT will still be turned on, but the menu bar icon will be gone. Is that not what you were after?

    [​IMG]
     
  5. madmacfan macrumors 6502

    Joined:
    Feb 19, 2012
    Location:
    London, United Kingdom
    #5
    I used to have an issue similar to yours when using a bluetooth keyboard and mouse when my Macbook was in clamshell mode, connected to the tv and every time the battery in the magic mouse or keyboard went below 20%, I would get the bluetooth icon reappearing in the menubar. Since I dragged the icon out of the menubar i haven't experienced this issue. Although it's not completely turned off it doesn't seem to drain the battery and for me it's a workaround for now at least.
     
  6. H.Finch thread starter macrumors regular

    Joined:
    Jun 9, 2013
    #6
    I'll try the 'drag method', I really hope it works. Don't get me wrong, when I uncheck the 'show menu icon' it goes away...but as soon as my mouse or keyboard hit below 10% battery, there it is again... showing the icon, then 3 dots, then the icon, then 3 dots, with a second itervall or so. So unchecking works... for about an x number of days...but then my mouse goes down in battery again, it gives me an on screen message saying my mouse is low in power...and then the icon is back.
     
  7. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #7
    Ahhh.... gotcha. I did not understand your issue. So even with it dragged off it pops up the low battery warning. Don't know a solution to that.
     
  8. H.Finch thread starter macrumors regular

    Joined:
    Jun 9, 2013
    #8
    Yeah sorry if I was a little vague. That's the problem indeed... I'm not sure if its just on my OSX, or if I'm the ony one seeing this as a problem... or, maybe other people just switch out the batteries long before their devices hit 10%... that might be an option, and then I'd never see the icon again...
    I'll think about that. Its just that I've always heard batteries remain in better condition if you let them get to 'totally' empty, and then recharge.
     
  9. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #9
    I don't think that is as much an issue with newer batteries. I use Sanyo Eneloops and just swap them whenever they get much below 30-40% and it does not seem to bother them.
     

Share This Page