Annoying Epson Print Monitor Behavior

Discussion in 'Mac Accessories' started by wasjoe, Jul 28, 2008.

  1. wasjoe macrumors newbie

    Joined:
    Feb 28, 2008
    #1
    I wonder if anyone else has encountered/ been annoyed by this.

    When printing multiple documents on an Epson Stylus Photo R280, the "Epson Printer Monitor" window forces itself to the front every single time a new doc starts printing from the queue.

    You can be typing in another application, and each time a new doc begins printing, you lose your place and have to click back to what you were doing because the print monitor springs to the front.

    Does anyone know how to turn this off? Can anyone think of a way to stop it? I want my BACKGROUND printing back!

    I'm on a Mac Pro 2.66, OS X 10.5.4. This occurs regardless of which program I print from. I searched the Epson website, no dice. Googled my key terms, no luck there either.

    Thanks in advance!
     
  2. dengar169 macrumors member

    Joined:
    Sep 20, 2007
    #2
    Are you running the newest drivers? I am using what ever driver originally came w/ my printer. I have an epson printer and haven't experienced this problem. If that is the case, I wont be updating my drivers any time soon.
     
  3. wasjoe thread starter macrumors newbie

    Joined:
    Feb 28, 2008
    #3
    I did upgrade to the newer driver version from Epson's website, but the problem existed with the driver that came with the printer. Upgrading did not change the behavior.
     
  4. wasjoe thread starter macrumors newbie

    Joined:
    Feb 28, 2008
    #4
    Just thought I'd leave an update here in case any of the 78 of you who've viewed this become curious.

    I called Epson (yikes)!

    Initial recommendation from tech support ("Jack," probably in Bangalore or somewhere exotic) was that I could delete the monitor app (!), but he allowed that that would eliminate head cleaning, other utility functions, etc! I tried to pin him down on whether this is the NORMAL behavior of the software (ie, is it just a poorly-designed driver) or is there something wrong? He put me on hold twice for five+ minutes at a time, and finally he decided that this is normal behavior for the software. So it took 20 minutes, but at least I've verified that this is bad software design by Epson, and not a problem or correctable situation.

    I'm surprised, though, that nobody else (apparently) has ever noticed or been frustrated by constant interruptions while you're trying to print in the background!! I've owned a lot of Epson printers over the years (at least 7 or 8, dating back to 1997), and I've never seen this, not since background printing was invented.

    Thanks, Epson!
     
  5. Wh1te Rabb1t macrumors newbie

    Joined:
    Sep 24, 2008
    #5
    The Culprit! The annoying pop up is in this folder:

    Main Hard Drive/Library/Printers/EPSON/InkjetPrinter/EPW/

    None of those applications in the EPW folder need to be turned on. I just compressed them into a ZIP file so I didn't have to throw them away. The standard Epson Printer monitor program and all printer sharing still works.

    My Epson was being shared with four other workstations and I had no idea when the next print document would show up. That pop up application is really annoying - what was Epson thinking?
     
  6. wasjoe thread starter macrumors newbie

    Joined:
    Feb 28, 2008
    #6
    Interesting. I don't actually HAVE an EPW folder in my system anywhere. I agree, this behavior is awful design, but it's just like so many things in life, eventually one becomes accustomed to routine awfulness. Thanks, Epson!

    Can you post the details of the files you zipped? Maybe I have them, just located elsewhere?

    I'm using the driver version 3.85 currently. Does that match yours?
     
  7. Wh1te Rabb1t macrumors newbie

    Joined:
    Sep 24, 2008
    #7
    Did you actually search the file tree, or just use your finder to look for the EPW folder? The Finder ain't gonna "Find" it by default because its in the Main system Library folder. Try a 'manual' search through your directory. The other solution is when it 'pops' up in the dock - to right click the "Show in Finder" link.

    The Applications in that folder include:
    IJEPWAgent
    EPSON Low Ink Reminder
    EPSON Printer Monitor <<<--- EVIL!!!!!!
     
  8. LGTV33 macrumors newbie

    Joined:
    Nov 23, 2008
    #8
    Thanks... My Epson CX8400 can manually do head cleanings, other utility functions so this fix of zipping the file works perfect for me!
     
  9. sleepingworker macrumors 6502a

    sleepingworker

    Joined:
    Feb 26, 2003
    Location:
    Manhattan, NY
    #9
    So thankful to see this thread and know that I'm not alone in this problem. And thank you WR. Now I don't get the pop up - but I do get a pop up that says "The application can not be found". Also, I can't seem to delete the file "IJEPWAgent" after I tried to archive it, and now I can't archive it without an error message! Any suggestions? Thank you.
     
  10. acdha macrumors newbie

    Joined:
    Dec 6, 2008
    #10
    I found an even more annoying way for this to happen: every time another machine on the network connects to the printer, up pops the useless window. Here's the cleanest way to disable it using the Terminal:

    First, stop the currently running process:
    Code:
    launchctl stop com.epson.epw.agent
    
    Second, tell launchd to permanently disable the task using -w so it'll set Disable=true in the config file:
    Code:
    sudo launchctl unload -w /Library/LaunchAgents/com.epson.epw.agent.plist 
    
    (Technically, these should be one step but a design limitation in launchd means you have to do it in two because the first command runs as you and the second needs to run using sudo so it has administrative access)

    If you ever want it back:

    Code:
    sudo launchctl load -w /Library/LaunchAgents/com.epson.epw.agent.plist 
    
     
  11. wasjoe thread starter macrumors newbie

    Joined:
    Feb 28, 2008
    #11
    Thanks to all who have responded to this. When I first posted, I was on 10.5.4. As it happens, somewhere along the way, the problem stopped. I just tested it again, and the app does NOT force its way to the front any more. So either OS X update 10.5.5 or 10.5.6 appears to have fixed it. (I'd gotten so used to it, I'm not even sure when in the last 4-5 months it stopped happening!)

    I did not upgrade the printer driver in any way in this time, so it does look like an OS update that fixed it.

    The print monitor app now works as it should, it opens in the background on printing, and never pops to the front. Yay!
     
  12. Van Helsing macrumors newbie

    Joined:
    Aug 23, 2004
    Location:
    England
    #12
    Simply renaming or compressing the application results in a similar pop-up window, but one that says the application could not be found, equally annoying.

    Secondly, those terminal commands no longer work. I can verify the plist is now set to disabled by viewing the keys inside, however that does not prevent the Printer Monitor from opening.

    Any thoughts?
     
  13. thomasjhowey macrumors newbie

    Joined:
    Jan 18, 2005
    #13
    This worked for me...

    I got my new Macbook Pro today along with an Epson SX515W and was also bugged with this problem. However, after going to:

    Main Hard Drive/Library/Printers/EPSON/InkjetPrinter/

    as described by Wh1te Rabbit (to whom I am most grateful), I zipped up the applications that were there and... problem solved!

    Note: I did not find an EPW directory either, but just zipped up the printer utility (and the low ink reminder app, which I imagine would get rather annoying).

    I'm just smacking my head over not being sharp enough to just search for the application and deal with it myself - must be the gin and tonic I've been drinking...
     

Share This Page