Annoying Extern HD Issue with Sierra & Late '13 rMBP

Discussion in 'macOS Sierra (10.12)' started by tock172, Oct 30, 2016.

  1. tock172 macrumors newbie

    Joined:
    Jul 21, 2011
    Location:
    San Diego
    #1
    Hello all,

    Ever since updating to macOS Sierra, I've been having an issue with my 2TB Seagate desktop hard drive and my late 2013, 13" Retina MacBook Pro. In short, if the computer goes to sleep with the hard drive connected, upon waking the computer, I cannot eject the drive or use it without Finder crashing, forcing me to hard boot the computer.

    A few things I've tried (unsuccessfully) to remedy the issue:
    • Reinstalled macOS Sierra
    • Booted up using Command + R and ran first aid on everything (which found problems on the drive and fixed them, but the problem remained)
    • Transferred my data to another drive, reformatted the drive in question.
    • Tried to replicate the symptoms on an identical Seagate external HD I have - Same exact issues.
    • Took MBP to Genius Bar, Genius ran full diagnostics - no issues found.
    Does anyone have any ideas on what could be going wrong here? It's driving me insane and I do not like having to turn my MacBook pro off by holding the power button a few times a week.

    If it's of any importance, the hard drive is a 2TB that's formatted to use 500GB as my Time Machine, and another 1.5 TB of regular storage.

    Thanks for reading! :)
     
  2. tock172 thread starter macrumors newbie

    Joined:
    Jul 21, 2011
    Location:
    San Diego
    #3
    Thanks for the feedback.

    Jettison actually revealed some more information relating to the issue. I set up Jettison to eject the drives before the computer sleeps - which it did. However upon waking up, Jettison seemed unable to remount the drives. Nothing reappeared on the screen and when I tried to launch disk utility, it couldn't load either. I then shut the computer down successfully through macOS (not a hard boot). It seems like there's some glitch not with the drives, but with macOS. Does this provide any insight?
     
  3. MacUser2525 macrumors 68000

    MacUser2525

    Joined:
    Mar 17, 2007
    Location:
    Canada
    #4
    Not to me does open another way of doing it though. Open Terminal (in Applications/Utilities folder) then type in then enter diskutil list this gives you listing of all drives seen by the OS. If it shows the external then a diskutil mount /dev/disk2s2 would mount the partition of the third disk in the system second partition on it. You will see the correct disk?s? to use in the output of the command as it relates to the name of you partition.
    An example from my system below.

    Code:
    MacUser2525:~$ diskutil list
    
    /dev/disk0 (internal, physical):
    
       #:                       TYPE NAME                    SIZE       IDENTIFIER
    
       0:      GUID_partition_scheme                        *120.0 GB   disk0
    
       1:                        EFI EFI                     209.7 MB   disk0s1
    
       2:                  Apple_HFS EL_SSD                  39.3 GB    disk0s2
    
       3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
    
       4:                  Apple_HFS iMac_TM                 79.6 GB    disk0s4
    
    MacUser2525:~$ diskutil mount /dev/disk0s1
    
    Volume EFI on /dev/disk0s1 mounted
    
    Here you can see I mounted the EFI partition on my backup boot drive just change to unmount in the second command if you ever want to unmount a partition..
     

Share This Page