Annoying iMessage issue

mrmeister

macrumors regular
Original poster
May 26, 2010
139
1
Ok, so I'm having a really annoying problem with iMessage:

Me and my girlfriend both have iPhone 5S's (7.0.4), and we were both able to use iMessage with no problems. iMessage is kind of essential for us because she lives in the US and I live in the UK. She came over to the UK for a month and I got her a UK SIM, just temporarily, so she could use the phone over here - again, iMessage still worked fine but now to a new number.

The problem is, now she's arrived back home and put her American SIM in, I can't imessage her. I can only SMS, yet she CAN imessage me. We can both imessage every other iphone contact in our contacts list without a problem, it's just my UK phone that can't send an imessage to her US phone.

We've tried the basics of turn imessage off and on, resetting networks, hard reset the phone, our send and receive lists match (both phone and email, starting conversation from the phone which is what we've always had). I'm just totally lost. I have no idea why it's not working, it just doesn't seem logical at all.

Sorry if any of this doesn't make sense, I'm very tired and just wanted to get something out before I sleep so I can hopefully have a response by morning. If anything needs clarifying, just let me know.
Thanks
 

ugcop

macrumors 6502a
Mar 15, 2012
599
103
Traveling @ Warp Speed ...... USA
I had a similar issue in that after changing a phone number in a contact, every time I tried to send a message it would pull up the old number. It seems that old data has to be overwritten before it stops coming up in a search. I used an app called ishredder. It overwrites all open space in memory. At times it is free but right now it is $1.99

I think the problem is your phone by the way.
 

Tumbleweed666

macrumors 68000
Mar 20, 2009
1,654
50
Near London, UK.
Have you tried deleting her from your contacts and then adding her back in again with only original number in?
Also, can you iMessage anyone else? Is it just her?
 

bkribbs

macrumors 65816
Jan 15, 2012
1,178
0
Let me see if I have the same thing.

My messages send fine as iMessages to my friend from my iPad, but on my phone they only send and receive as texts. She can send as texts only.

I guess that's different but similar. I figure deleting the thread and contact would add it but I don't want to do that so...
 

mrmeister

macrumors regular
Original poster
May 26, 2010
139
1
Have you tried deleting the number then adding it again in contacts?
Yes, i've tried that and still no luck annoyingly

I had a similar issue in that after changing a phone number in a contact, every time I tried to send a message it would pull up the old number. It seems that old data has to be overwritten before it stops coming up in a search. I used an app called ishredder. It overwrites all open space in memory. At times it is free but right now it is $1.99

I think the problem is your phone by the way.
I was assuming the problem was my phone, but i just can't see why it's suddenly deciding not to work??

It's not that it's pulling up the old number, it's just that it won't recognise that it's an iPhone and that it can send an iMessage to it, EVEN THOUGH it allows iMessages to be received from the number in question.

Reset network settings
In my original post i state that i've tried this

Have you tried deleting her from your contacts and then adding her back in again with only original number in?
Also, can you iMessage anyone else? Is it just her?
I've tried this, and as stated in my original post we can both imessage every other iphone contact in our contacts list without a problem, it's just my UK phone that can't send an imessage to her US phone.

I guess that's different but similar. I figure deleting the thread and contact would add it but I don't want to do that so...
I'd quite like to keep all of the message history if possible, i like to hold onto things...
 

Xenc

macrumors 65816
May 8, 2010
1,030
173
London, England
Try sending an iMessage to her Apple ID instead of her phone number. Assuming the address is enabled in FaceTime Settings, she should receive the iMessage on her phone.
 

mrmeister

macrumors regular
Original poster
May 26, 2010
139
1
Try sending an iMessage to her Apple ID instead of her phone number. Assuming the address is enabled in FaceTime Settings, she'll receive the iMessage on her phone.
But then won't I lose all of the conversation history (because it'll start a new thread) and it won't be able to send an SMS in the event that one of us is offline?
 

Xenc

macrumors 65816
May 8, 2010
1,030
173
London, England
But then won't I lose all of the conversation history (because it'll start a new thread) and it won't be able to send an SMS in the event that one of us is offline?
Assuming it works, it would at least allow you to message one another when you have a network connection. You wouldn't lose your previous message thread.
 

mrmeister

macrumors regular
Original poster
May 26, 2010
139
1
Assuming it works, it would at least allow you to message one another when you have a network connection. You wouldn't lose your previous message thread.
So this would be a temporary fix, yes, but ideally i'd like to fix the problem that is the phone number

----------

The even weirder thing is, if i delete her email from contacts, i can still FaceTime her on her number alone
 

mrmeister

macrumors regular
Original poster
May 26, 2010
139
1
I tried deleting the thread and that didn't work, then i've tried restoring the phone and that still didn't work... I just don't get it at all
 

RokkenRock

macrumors member
Aug 24, 2010
50
7
Do you send messages from and to a phone number or email address? My wife and I send from our respective mobileme address and imessage is working just fine no matter we use our normal sim cards or sim cards that we buy locally while traveling.
 

CosmoPilot

macrumors 65816
Nov 8, 2010
1,423
86
South Carolina
Do you have any other Apple devices tied to iMessage? If so, turn iMessage off for everything. Do this for both you and her. Then with all iMessage systems off, hard reboot the iPhones. Turn iMessage back on for the iPhones only. Try send iMessages. Then turn on other iMessage capable devices one at a time. Ensure phone number (the correct number is registered) in settings > message is correct in the caller ID section. Finally, ensure new messages are sent from phone number. Do this on all devices (for Macs, this is under preferences).

Hope this helps.
 

Gpulvi

macrumors member
Oct 11, 2011
85
11
Buenos Aires, Argentina
Help!

I've recently came back from Rome, where I used a TIM (local company) SIM card. When I put again my local SIM card, the italian telephone number remained and my old number never appeared in FaceTime and iMessage. I can't activate both services with my cellphone number, only with my Apple ID.

When I look into "You can be reached by iMessage / FaceTime at:" I can see my Apple ID and the italian phone number.

I've changed the phone number in "Settings -> Phone", reseted network settings, I've restored the iPhone, set time zone to manual and then to automatic, verified my country in my Apple ID, deleted my number in my contact card, logged out both services in my Mac and my iPad... But the problem is still there.

Can anybody help me?

Thanks in advance
 

The Doctor11

macrumors 603
Dec 15, 2013
5,922
1,334
New York
Try backing up to icloud resting it back to factory settings and then restore from icloud. Good luck.

----------

I've recently came back from Rome, where I used a TIM (local company) SIM card. When I put again my local SIM card, the italian telephone number remained and my old number never appeared in FaceTime and iMessage. I can't activate both services with my cellphone number, only with my Apple ID.

When I look into "You can be reached by iMessage / FaceTime at:" I can see my Apple ID and the italian phone number.

I've changed the phone number in "Settings -> Phone", reseted network settings, I've restored the iPhone, set time zone to manual and then to automatic, verified my country in my Apple ID, deleted my number in my contact card, logged out both services in my Mac and my iPad... But the problem is still there.

Can anybody help me?

Thanks in advance
Maybe it is something with the Rome number.
 

adnbek

macrumors 68000
Oct 22, 2011
1,523
490
Montreal, Quebec
On her phone, did you go to settings > messages > send and receive and make sure her American number shows up and has a checkmark next to it?
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.