Annoying iphone 4 slowness

Discussion in 'iPhone' started by alexxn, Mar 31, 2011.

  1. alexxn macrumors regular

    Joined:
    May 14, 2009
    Location:
    S. Fla
    #1
    So this is finally getting unbearable....my iphone 4, IOS 4.3, I can be sitting on my couch (or other places) and have 2-3 bars of 3G AND almost a full signal to my WiFi and browsing the internet CRAWLS - to the point where the page will not fully load and I'll get the Safari messages that it can't connect, etc. Also it's painfully slow sending text messages.

    What could possibly be going on here ? I've had the phone since it came out last year and honestly the speed has never impressed me.

    BTW internet speed tests have always been decent, the last was 3.75 down and 2.24 up.
     
  2. BHP41 macrumors 6502a

    BHP41

    Joined:
    Jul 21, 2010
    Location:
    United States of America
    #2
    Don't know what going on but try turning airPlane mode on and off. It should have to establish the connections again.
     
  3. alexxn thread starter macrumors regular

    Joined:
    May 14, 2009
    Location:
    S. Fla
    #3
    I've tried that with no success :confused:
     
  4. heisenberg123 macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #4
    have your tried a hard reset (hold power button and home button untill the apple logo appears then let go)
     
  5. hobo.hopkins macrumors 6502a

    hobo.hopkins

    Joined:
    Jul 30, 2008
    #5
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_2_6 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8E200 Safari/6533.18.5)

    Do you experience these problems wherever you go? Or is it just possibly a problem in your area?
     
  6. alexxn thread starter macrumors regular

    Joined:
    May 14, 2009
    Location:
    S. Fla
    #6
    That was the first thing I tried, along with resetting the network connections, etc
     
  7. heisenberg123 macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #7
    what about reseting your wireless router?

    also when my wifi doesn work on my iphone its usually when im dowloaing a large file on my laptop, could that be the case?
     
  8. alexxn thread starter macrumors regular

    Joined:
    May 14, 2009
    Location:
    S. Fla
    #8
    I'm never on both my laptop and my iphone at the same time so this isn't the case.

    I thought about the router but wouldn't the 3G take over ?
     
  9. heisenberg123 macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #9
    not always my phone will stay connected to a crappy wifi signal even if its not even a full bar, i have to tell my phone to ignore that wifi for 3G to pick up
     
  10. alexxn thread starter macrumors regular

    Joined:
    May 14, 2009
    Location:
    S. Fla
    #10
    Hmmm OK that makes sense, I'll try resetting the router (even though my Macbook Pro flies)

    I guess another thing I can try to isolate it is to keep it in Airplane mode so it just works off of WiFi and see what happens.

    My router is a good 5 years old, maybe it's time to bite the bullet and get an Airport Extreme base.
     
  11. Khanja macrumors newbie

    Joined:
    Mar 28, 2011
    Location:
    GA, usa
    #11
    what do you mean by "other places" ...do you have this problem at .. say a friends house (that has wifi) ?
    if not then its probly your router
     
  12. alexxn thread starter macrumors regular

    Joined:
    May 14, 2009
    Location:
    S. Fla
    #12
    I've had this happen at Starbucks for example also - mind you it isn't every time...you do have a point about the router however.
     
  13. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #13
    How much free space do you have?

    Some things you can try:

    Restart your router.
    Restart phone.
    Close all safari tabs.
    Contact Apple for support.
     
  14. jayenh macrumors 6502a

    Joined:
    Nov 13, 2008
    #14
    Also try deleting safari cache, cookies and history in settings > safari.
     
  15. alexxn thread starter macrumors regular

    Joined:
    May 14, 2009
    Location:
    S. Fla
    #15
    I NEVER thought of that actually, I just did it now to see.

    Does anyone know would upgrading to 4.3 have cleared my cache etc or has it been building up all this time ?
     
  16. vincenz macrumors 601

    vincenz

    Joined:
    Oct 20, 2008
    #16
    You could try restoring the phone and resyncing everything back up. Over time your iPhone builds up all that "Other" data that's stored on there. Something in there might be slowing it down too.
     
  17. alexxn thread starter macrumors regular

    Joined:
    May 14, 2009
    Location:
    S. Fla
    #17
    True I was just wondering as Ive had the phone almost a year and NEVER cleared any cache or anything else in Safari and it would make sense that it building up all this time has made it slower.

    All I've done have been IOS upgrades so unless they automatically empty out Safari cache etc its never been done.
     
  18. iceterminal macrumors 68000

    iceterminal

    Joined:
    May 25, 2008
    Location:
    Dallas Tx.
    #18
    +1
     
  19. iceterminal macrumors 68000

    iceterminal

    Joined:
    May 25, 2008
    Location:
    Dallas Tx.
    #19
    I do not believe upgrading the OS would clear out your cache. I could be wrong, but I don't think it would.

    Go in, clear out your cache. Reset your network setting. Tell your phone to forget the wifi network its on. Then restart your phone. Reconnect to your network, load up safari and see what happens.
     
  20. AndrewR23 macrumors 68040

    Joined:
    Jun 24, 2010
    #20

    Just wanted to add this fixed my slowness before and it hasn't been slow again.
     
  21. alexxn thread starter macrumors regular

    Joined:
    May 14, 2009
    Location:
    S. Fla
    #21
    Sounds easy enough, I'll give all this a try and report back ;)
     
  22. alexxn thread starter macrumors regular

    Joined:
    May 14, 2009
    Location:
    S. Fla
    #22
    OK, here goes.

    I did all of the above, forgot network settings, cleared all caches, etc

    First test I put the phone in airplane mode and had full to one bar less than full wireless G signal.

    Speed test as follows:

    9.86Mbps down, 2.23 Mpbs up

    Next I turned 3G back on and turned wireless off, I had 4 bars of 3G signal.

    Speed test:

    2.20Mbps down, 0.36Mpbs up

    Internet seems better but for some reason I thought it would be a little quicker and also I did get a server not responding, you have no internet connection happen when I was trying to click a photo in Facebook.

    Do the 3G and wireless speeds seem somewhat normal compared to other users ?

    Thanks again in advance for everyones suggestions.
     
  23. alexxn thread starter macrumors regular

    Joined:
    May 14, 2009
    Location:
    S. Fla
    #23
    P.S. my Macbook Pro got the following on the same speed test:

    16.26Mbps down, 2.49Mbps up
     

Share This Page