Annoying login change since swapping to SSD

Discussion in 'OS X El Capitan (10.11)' started by elf69, Dec 17, 2016.

  1. elf69 macrumors 65816

    elf69

    Joined:
    Jun 2, 2016
    Location:
    Cornwall UK
    #1
    ok so i added an ssd to my old 17" macbook pro.

    reinstalled El capitan via Target mode from my imac.
    Then used time machine to put all my data/apps etc back.

    all is good except that before with HDD the login page used to show my user name and the password box.
    Now it only shows my name and I need click the mouse button as tapping pad not work to bring up password box.

    Only I use the machine so I set it to auto login.

    Just wounder has el cap changed in last update?
     
  2. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #2
    Hi,

    you can change this to get the previous behavior : System Preferences / Users and groups, open the lock, click on "Options", select : "Display login window as : Name and password".
     
  3. elf69 thread starter macrumors 65816

    elf69

    Joined:
    Jun 2, 2016
    Location:
    Cornwall UK
    #3
    nope that option means I have to type my name and my password.

    I just leave it as auto sign in.
     
  4. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #4
    It sounds like perhaps Filevault is enabled. If it is, the computer will always require a password to unlock the disk before starting up, even if the automatic login option is enabled.
     
  5. elf69 thread starter macrumors 65816

    elf69

    Joined:
    Jun 2, 2016
    Location:
    Cornwall UK
    #5
    in auto login no password.

    if auto login was off, then the login screen would show my name and below it a grey box to type my password.

    Now i fitted an SSD my name but no password box.
    I have to click on name with mouse button as cannot tap. Then grey password box shows up.
     
  6. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #6
    hmm....
    Users & Groups pane/Login Options. Change "List of Users" to "Name & Password" ?
    With that "Name & Password" option, on Login, you will see blank boxes to fill in your account name, and password.

    Do you have more than one user listed in Users & Groups? If so, the "List of Users" will mean that you click on the User name before you will see the entry box for password, because there are other user names listed (such as Guest). If you remove all other accounts, and turn off the guest account, then you should see what you want in the login window
     
  7. elf69 thread starter macrumors 65816

    elf69

    Joined:
    Jun 2, 2016
    Location:
    Cornwall UK
    #7
    one user me, guest is off.

    no box for password until I click on my name.

    bypassed with auto login which is fine as only i use it and it always at home or work so other cannot use it anyway.
    just bit annoying.
     
  8. rshrugged macrumors 6502a

    Joined:
    Oct 11, 2015
    #8
    Try booting into Safe Mode then reboot into normal mode.

     
  9. elf69 thread starter macrumors 65816

    elf69

    Joined:
    Jun 2, 2016
    Location:
    Cornwall UK
    #9
    Thank you.
    That seems to have done it but took 3 attempts to get into safe mode.

    first two attempts turned laptop off after showing the apple loading screen for few seconds.
    Third try I got in.

    After reboot now have the password box to login without having to click my name.

    Thank you.
     
  10. rshrugged macrumors 6502a

    Joined:
    Oct 11, 2015
    #10
    You're welcome. :)
     

Share This Page