annoying macbook 30 second auto dimming help

Discussion in 'MacBook Pro' started by hvatsun, Aug 2, 2007.

  1. hvatsun macrumors newbie

    Joined:
    Aug 3, 2006
    #1
    hey there. I HATE that dimming of the screen that the macbook does once it is idle after about thirty seconds. It really disrupts watching videos online, and i can not figure out how to turn it off. can anyone help me? thanks!
     
  2. GimmeSlack12 macrumors 603

    GimmeSlack12

    Joined:
    Apr 29, 2005
    Location:
    San Francisco
    #2
    Check the Energy Saving Preference. That'll fix it.
     
  3. L`- macrumors newbie

    L`-

    Joined:
    Jul 6, 2007
    #3
  4. Siouxsie macrumors newbie

    Joined:
    Jul 14, 2007
    Location:
    Uppsala, Sweden
  5. Smoothie macrumors 6502

    Joined:
    Jun 23, 2007
    Location:
    California
    #5
    After looking into this a few weeks ago, I found posts that described this as a bug in the OS. Even if you've disabled auto dimming in the power settings, it will occur the next time you reboot. The only way to fix this is to go into the power settings, check the box for auto dimming and then uncheck it. You'll need to do this each time you reboot.
     
  6. GimmeSlack12 macrumors 603

    GimmeSlack12

    Joined:
    Apr 29, 2005
    Location:
    San Francisco
    #6
    I disagree with this. As this only happens to me when I'm on battery only. And even then I can simply go check the box in the Energy Savings. Of course I am only one man in a sea of inevitable exceptions.
     
  7. iW00t macrumors 68040

    iW00t

    Joined:
    Nov 7, 2006
    Location:
    Defenders of Apple Guild
    #7
    Are you sure?

    *checks power settings*

    Nope, not true. Never happens for me.
     
  8. zephead macrumors 68000

    zephead

    Joined:
    Apr 27, 2006
    Location:
    in your pants
    #8
    There's a little trick you have to do in Terminal: If you type pmset -g disk, you'll see that halfdim is set to 1 for both battery and AC power. Now, to disable the dimming, type sudo pmset -a halfdim 0 and type your password to disable the display dim. The -a (all) says to apply it across the board, -b is for battery, and -c is for charger (AC adapter).
     
  9. e12a macrumors 68000

    e12a

    Joined:
    Oct 28, 2006
    #10
    ths has been covered time and time again...and then some (this thread)

    http://docs.info.apple.com/article.html?artnum=304092

    wow just wow. Do we really need yet another thread on this? By the way i have found that apple's support method does not work. its a bug.
     
  10. zephead macrumors 68000

    zephead

    Joined:
    Apr 27, 2006
    Location:
    in your pants
    #11
    To add to my previous post, that Terminal command works restart after restart. Just type it and forget it, and your display isn't gonna dim.
     
  11. fltsdsurf macrumors newbie

    Joined:
    May 2, 2008
    #12
    Zephead's answer worked to perfection. I didn't set set everything to 0, just the charger. Thanks mang.
     

Share This Page