Annoying mail issue: Sends/receives from different accounts

Discussion in 'Mac Basics and Help' started by Hellishness, Apr 1, 2012.

  1. Hellishness macrumors 65816

    Hellishness

    Joined:
    Jan 27, 2010
    Location:
    Bay Area, CA
    #1
    So I have two accounts on my mail app, lets just call them 1 and 2. 1 is my main one, I've set everything to automatically send from that one. They're both gmail. If I do something like reply to a craigslist ad by clicking the email link (which is about 90% of my sent emails from my mail app), it'll send from account 1. When the person replies, it says that 1) I sent the original email from account 2, 2) the email back was sent to account 2, and 3) when I reply, it automatically sends from account 2.

    What do I do? It's extremely annoying, and I just end up using account 2 most of the time because I can't get it to work properly. Both accounts receive email fine, and 90% of the email that I get and don't reply to is to account 1.
     
  2. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #2
    Delete both accounts and setup again, making sure you check default account on the primary address you wish to use. I have two accounts and whatever I do the iCloud address appears in the list first....I have to switch to my primary account before sending....No big deal but annoying at times.
     
  3. hafr macrumors 68030

    Joined:
    Sep 21, 2011
    #3
    If you have an e-mail from account 2 highlighted (or in preview, whatever the correct term would be) in the "shared" inbox, or if you're in any folder belonging to account 2, any new mail will be set to send with account 2. Same goes for account 1.

    Very annoying. I have yet to find a setting that overrides this behavior, if someone knows how - please let me know :)
     
  4. Hellishness thread starter macrumors 65816

    Hellishness

    Joined:
    Jan 27, 2010
    Location:
    Bay Area, CA
    #4
    Good to know, thanks. I deleted both accounts and redid them, but there didn't seem to be any settings really on which is the primary account. I'll update this thread if it's still an issue.
     

Share This Page