Annoying MBP display issue (Leopard)

Discussion in 'MacBook Pro' started by X-Morgan, Jan 19, 2008.

  1. X-Morgan macrumors member

    Joined:
    Jul 14, 2006
    #1
    Hey there,

    Ever since upgrading to Leopard (clean install) I've had a very annoying problem with my MacBook Pro.

    Basically, after a few minutes, the display brightness goes to zero, though I can still see that the TFT is still switched on (like seeing faint images on a YouTube video) and in order to get it back up again I need to move the mouse.

    This is really annoying if I'm reading something or watching something where there is no user input.

    Anyone else got this problem? More better, anyone got a solution to this?

    This never happened on Tiger.

    I checked all my System Preferences and energy saver options and nothing is ticked which would let me to belive that the display might dim down or be switched off.

    Cheers

    Chris :)
     
  2. spring macrumors regular

    Joined:
    Oct 30, 2007
    Location:
    Bergen County, NJ
    #2
    Mine does this too, but it doesn't go completely dim like you said. Mine only dims to about 50% brightness. It used to bother me a lot, but not as of late. My friends Macbook does this too.

    You can download Caffeine to temporarily help you with this issue. It basically prevents the screen from dimming or going to sleep.
     
  3. X-Morgan thread starter macrumors member

    Joined:
    Jul 14, 2006
    #3
    Fantastic! Great little program that does exactly what it says on the tin.

    Does anyone know why Leopard would turn off the LED though? Very pointless and would only be necessary when not plugged in. All my energy saving preferences are at max performance and max brightness.
     
  4. cms2 macrumors 6502

    cms2

    Joined:
    Aug 4, 2007
    Location:
    Texas
    #4
    I don't know why, but yeah, Leopard has added this annoying trait to my MBP. It dims the screen by about 95%. I can just faintly see things like my screensaver running, etc. I've checked all the settings. It's really annoying.
     
  5. theman macrumors 6502a

    Joined:
    Jul 26, 2007
    #5
    just go to system prefs>energy saver and adjust when the display goes to sleep. also, if you go to "options" tab on that page unclick the "automatically reduce screen brightness before display sleep"

    that SHOULD solve it. these same options were there in tiger.

    also, Caffeine is a GREAT app. I use it while watching youtube, or reading papers/long webpages.
     
  6. cms2 macrumors 6502

    cms2

    Joined:
    Aug 4, 2007
    Location:
    Texas
    #6
    That's the problem. It doesn't matter how you adjust the time when the display goes to sleep, it just goes. And I have unclicked the reduce screen brightness before sleep option. Just to be sure I just double-checked. Leopard sleeps when it wants to. It's a big cat. I don't argue with it.. :D
     

Share This Page